summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-01-21 18:30:01 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-01-21 18:30:01 +0000
commit69596d021ec407688cf27339097c8c975d3a18e3 (patch)
treef9ddadfe1c72d23310ba76885db59b3829e68400 /x11-libs/guile-gtk/guile-gtk-0.19-r1.ebuild
parentDisable modelines by default. Fixes security bug #14088 (diff)
downloadgentoo-2-69596d021ec407688cf27339097c8c975d3a18e3.tar.gz
gentoo-2-69596d021ec407688cf27339097c8c975d3a18e3.tar.bz2
gentoo-2-69596d021ec407688cf27339097c8c975d3a18e3.zip
Examples now installed inte right place. Closes #14266.
Diffstat (limited to 'x11-libs/guile-gtk/guile-gtk-0.19-r1.ebuild')
-rw-r--r--x11-libs/guile-gtk/guile-gtk-0.19-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-libs/guile-gtk/guile-gtk-0.19-r1.ebuild b/x11-libs/guile-gtk/guile-gtk-0.19-r1.ebuild
new file mode 100644
index 000000000000..147083455fec
--- /dev/null
+++ b/x11-libs/guile-gtk/guile-gtk-0.19-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/guile-gtk-0.19-r1.ebuild,v 1.1 2003/01/21 18:30:01 mholzer Exp $
+
+DESCRIPTION="GTK+ bindings for guile"
+SRC_URI="http://www.ping.de/sites/zagadka/guile-gtk/download/${P}.tar.gz"
+HOMEPAGE="http://www.ping.de/sites/zagadka/guile-gtk/"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="=dev-util/guile-1.4*
+ =x11-libs/gtk+-1.2*"
+
+src_compile() {
+ patch < ${FILESDIR}/${P}-Makefile.in.patch || die "patch failed"
+ econf
+ emake || die
+}
+
+src_install() {
+ einstall
+
+ dodoc INSTALL README* COPYING AUTHORS ChangeLog NEWS TODO
+ insinto /usr/share/guile-gtk/examples
+ doins ${S}/examples/*.scm ${S}/examples/*.xpm
+}