summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-05-15 12:47:18 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-05-15 12:47:18 +0000
commit4cf6e2c34a774630a7352b875cbe3d274a8311c4 (patch)
tree3e15e1b58c43182f97b7b04963c22b90988a5bf7 /x11-libs/qt
parentlooks like i committed a borken version by accident. reverting (diff)
downloadgentoo-2-4cf6e2c34a774630a7352b875cbe3d274a8311c4.tar.gz
gentoo-2-4cf6e2c34a774630a7352b875cbe3d274a8311c4.tar.bz2
gentoo-2-4cf6e2c34a774630a7352b875cbe3d274a8311c4.zip
added qt 3.0.4.1
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog8
-rw-r--r--x11-libs/qt/files/digest-qt-3.0.4.11
-rw-r--r--x11-libs/qt/qt-3.0.4.1.ebuild130
3 files changed, 138 insertions, 1 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 0cd23ad1c600..fdf0fe8d0789 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.14 2002/05/11 08:42:57 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.15 2002/05/15 12:47:18 verwilst Exp $
+
+*qt-3.0.4.1 (14 May 2002)
+
+ 14 May 2002; Bart Verwilst <verwilst@gentoo.org> changelog:
+ QT-copy of QT 3.0.5, fixes some quite nasty bugs, because qt 3.0.4 seems
+ to add more bugs than it fixes..
11 May 2002; Dan Armak <danarmak@gentoo.org> changelog:
Fix bug #2483 (missing lcms dep)
diff --git a/x11-libs/qt/files/digest-qt-3.0.4.1 b/x11-libs/qt/files/digest-qt-3.0.4.1
new file mode 100644
index 000000000000..e5d0ef5594fd
--- /dev/null
+++ b/x11-libs/qt/files/digest-qt-3.0.4.1
@@ -0,0 +1 @@
+MD5 aba3e78cde90d98a753ffd0d6d07a0cf qt-copy-3.0.4.tar.bz2 13403885
diff --git a/x11-libs/qt/qt-3.0.4.1.ebuild b/x11-libs/qt/qt-3.0.4.1.ebuild
new file mode 100644
index 000000000000..126d1ebb35bb
--- /dev/null
+++ b/x11-libs/qt/qt-3.0.4.1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.4.1.ebuild,v 1.1 2002/05/15 12:47:18 verwilst Exp $
+
+PV=3.0.4
+S=${WORKDIR}/qt-copy-${PV}
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+
+SRC_URI="ftp://ftp.kde.org/pub/kde/stable/3.0.1/src/qt-copy-${PV}.tar.bz2"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ media-libs/lcms
+ >=media-libs/libmng-1.0.0
+ gif? ( media-libs/giflib
+ media-libs/libungif )
+ nas? ( >=media-libs/nas-1.4.1 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( =dev-db/postgresql-7.1.3* )"
+
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ export QTDIR=${S}
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' \
+ -e 's:|-repeater|:|-nas-sound|-repeater|:' configure.orig > configure
+
+}
+
+src_compile() {
+
+ export QTDIR=${S}
+
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -qt-imgfmt-{jpeg,mng,png} ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread -xft || die
+
+ export QTDIR=${S}
+
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+
+ export QTDIR=${S}
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+
+ # version symlinks - 3.0.3->3.0->3->.so
+ ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
+ ln -s libqt-mt.so.3.0 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqt-mt.so.${PV} libqt.so.${PV}
+ ln -s libqt-mt.so.3.0 libqt.so.3.0
+ ln -s libqt-mt.so.3 libqt.so.3
+ ln -s libqt-mt.so libqt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
+ -e "s:${WORKDIR}:${QTBASE}:" \
+ -e "s:/usr/local/qt:${QTBASE}:" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}