summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-04 00:28:33 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-04 00:28:33 +0000
commit55f5dbe666a3f544281eb3a41783802104fe1bc2 (patch)
tree79aa49bb6e6c586462dc6b8e0c97b48dd1937491 /x11-libs/xcb-util-image
parentalpha stable, bug 486302. (diff)
downloadgentoo-2-55f5dbe666a3f544281eb3a41783802104fe1bc2.tar.gz
gentoo-2-55f5dbe666a3f544281eb3a41783802104fe1bc2.tar.bz2
gentoo-2-55f5dbe666a3f544281eb3a41783802104fe1bc2.zip
Add patch for build error, bug #423909.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs/xcb-util-image')
-rw-r--r--x11-libs/xcb-util-image/ChangeLog6
-rw-r--r--x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch46
-rw-r--r--x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild6
3 files changed, 56 insertions, 2 deletions
diff --git a/x11-libs/xcb-util-image/ChangeLog b/x11-libs/xcb-util-image/ChangeLog
index 3af1a87c5704..ef9351b0ae98 100644
--- a/x11-libs/xcb-util-image/ChangeLog
+++ b/x11-libs/xcb-util-image/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/xcb-util-image
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-image/ChangeLog,v 1.18 2013/02/23 02:48:33 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-image/ChangeLog,v 1.19 2013/11/04 00:28:33 chithanh Exp $
+
+ 04 Nov 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xcb-util-image-0.3.9-return-type.patch, xcb-util-image-0.3.9.ebuild:
+ Add patch for build error, bug #423909.
23 Feb 2013; Zac Medico <zmedico@gentoo.org> xcb-util-image-0.3.9.ebuild:
Add ~arm-linux keyword.
diff --git a/x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch b/x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch
new file mode 100644
index 000000000000..d1ebc397a942
--- /dev/null
+++ b/x11-libs/xcb-util-image/files/xcb-util-image-0.3.9-return-type.patch
@@ -0,0 +1,46 @@
+From 3577db110e03985d4486cae6caf3ceb5696c45e9 Mon Sep 17 00:00:00 2001
+From: Jon TURNEY <jon.turney@dronecode.org.uk>
+Date: Thu, 20 Dec 2012 22:56:28 +0000
+Subject: Fix compilation when NDEBUG is defined
+
+XORG_DEFAULT_OPTIONS enables -Werror=return-type
+
+xcb_image_get_pixel() and xcb_image_create_native() assume assert(0) is
+noreturn, and don't return a value in that case. But assert(0) isn't noreturn
+if NDEBUG is defined.
+
+Fix this by returning a suitable value.
+
+(Also, on the MinGW target, assert(0) is non-standard and may return even in the
+!NDEBUG case, as the C runtime may ask the user if they want to abort or not...)
+
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c: In function 'xcb_image_get_pixel':
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c:754:1: error: control reaches end of non-void function [-Wreturn-type]
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c: In function 'xcb_image_create_native':
+/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c:190:1: error: control reaches end of non-void function [-Wreturn-type]
+
+Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk>
+Signed-off-by: Peter Harris <pharris@opentext.com>
+---
+diff --git a/image/xcb_image.c b/image/xcb_image.c
+index e426cbd..101aa4f 100644
+--- a/image/xcb_image.c
++++ b/image/xcb_image.c
+@@ -187,6 +187,7 @@ xcb_image_create_native (xcb_connection_t * c,
+ assert(0);
+ }
+ assert(0);
++ return NULL;
+ }
+
+
+@@ -751,6 +752,7 @@ xcb_image_get_pixel (xcb_image_t *image,
+ default:
+ assert(0);
+ }
++ return 0;
+ }
+
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild b/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild
index 7b6bdf31862c..6f7fb05b9b72 100644
--- a/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild
+++ b/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild,v 1.9 2013/02/23 02:48:33 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util-image/xcb-util-image-0.3.9.ebuild,v 1.10 2013/11/04 00:28:33 chithanh Exp $
EAPI=4
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.1
test? ( >=dev-libs/check-0.9.4 )"
+PATCHES=(
+ "${FILESDIR}"/${P}-return-type.patch
+)
+
pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_with doc doxygen)