summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2004-01-30 06:01:28 +0000
committerNick Hadaway <raker@gentoo.org>2004-01-30 06:01:28 +0000
commit772524308e7e8ea55bd77c88c0bb41ab534921e6 (patch)
treee59c0b30daf66692c354fad0fb7af20b4dda5e89 /x11-libs/xosd/xosd-2.2.5-r1.ebuild
parentautoconf fix (diff)
downloadgentoo-2-772524308e7e8ea55bd77c88c0bb41ab534921e6.tar.gz
gentoo-2-772524308e7e8ea55bd77c88c0bb41ab534921e6.tar.bz2
gentoo-2-772524308e7e8ea55bd77c88c0bb41ab534921e6.zip
Added xinerame use variable and configure options. Adjusted xmms configure options so it actually works. Addressed bug #39800 and the creation of /no.
Diffstat (limited to 'x11-libs/xosd/xosd-2.2.5-r1.ebuild')
-rw-r--r--x11-libs/xosd/xosd-2.2.5-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-libs/xosd/xosd-2.2.5-r1.ebuild b/x11-libs/xosd/xosd-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..a96c4124caaa
--- /dev/null
+++ b/x11-libs/xosd/xosd-2.2.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/xosd-2.2.5-r1.ebuild,v 1.1 2004/01/30 06:01:28 raker Exp $
+
+IUSE="xinerama xmms"
+
+DESCRIPTION="Library for overlaying text/glyphs in X-Windows X-On-Screen-Display plus binary for sending text from command line"
+HOMEPAGE="http://www.ignavus.net/"
+SRC_URI="http://www.ignavus.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa"
+
+DEPEND="virtual/x11
+ xmms? ( media-sound/xmms >=media-libs/gdk-pixbuf-0.22.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-xmms-trackpos.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ use xinerama || myconf="${myconf} --disable-xinerama"
+
+ use xmms || myconf="${myconf} --disable-new-plugin"
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS COPYING README
+
+ if [ -d ${D}no ]; then
+ rmdir ${D}no
+ fi
+}