summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-05 22:49:44 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-05 22:49:44 +0000
commit2203eec2ac998dc3d6fd79b0228f282f621a995c (patch)
treeb9759631a2377bb9b1703ebb523389c599812fc1 /x11-libs
parentsome updates (diff)
downloadgentoo-2-2203eec2ac998dc3d6fd79b0228f282f621a995c.tar.gz
gentoo-2-2203eec2ac998dc3d6fd79b0228f282f621a995c.tar.bz2
gentoo-2-2203eec2ac998dc3d6fd79b0228f282f621a995c.zip
added, thanks Azarah
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/gtk+-1.2.10-r4.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/x11-libs/gtk+/gtk+-1.2.10-r4.ebuild b/x11-libs/gtk+/gtk+-1.2.10-r4.ebuild
new file mode 100644
index 000000000000..7e98826ea601
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-1.2.10-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r4.ebuild,v 1.1 2001/10/05 22:49:44 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gtk"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${A}
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}
+ http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}"
+
+DEPEND="virtual/glibc virtual/x11
+ >=dev-libs/glib-1.2.10"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/gtk-1.2.10.patch || die
+}
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11 \
+ --with-xinput=xfree \
+ --with-x \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ preplib /usr
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING
+ dodoc NEWS* README* TODO
+ docinto docs
+ cd docs
+ dodoc *.txt *.gif text/*
+ cd html
+ docinto html
+ dodoc *.html *.gif
+
+ #install nice, clean-looking gtk+ style
+ insinto /usr/share/themes/Gentoo/gtk
+ doins ${FILESDIR}/gtkrc
+}
+
+pkg_postinst() {
+ echo
+ echo **********************************************************************
+ echo * Older versions added /etc/X11/gtk/gtkrc which changed settings for *
+ echo * all themes it seems. Please remove it manually as it will not due *
+ echo * to /env protection. *
+ echo * *
+ echo * NB: The old gtkrc is available through the new Gentoo gtk theme. *
+ echo **********************************************************************
+ echo
+}