summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-17 15:04:20 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-17 15:04:20 +0000
commit4ea359d8b71de20fc7b516f7a29855c60e4ed216 (patch)
treefb35d94618a13535da198f401fe8553bfccbdaa9 /x11-libs
parentUpdated the wrapper once more. (diff)
downloadgentoo-2-4ea359d8b71de20fc7b516f7a29855c60e4ed216.tar.gz
gentoo-2-4ea359d8b71de20fc7b516f7a29855c60e4ed216.tar.bz2
gentoo-2-4ea359d8b71de20fc7b516f7a29855c60e4ed216.zip
Added opengl useflag.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog5
-rw-r--r--x11-libs/qt/qt-3.1.0.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index b7a7425ea184..8b3385c0135e 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.32 2002/11/15 15:12:16 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.33 2002/11/17 15:04:20 karltk Exp $
+
+ 17 Nov 2002; Karl Trygve Kalleberg <karltk@gentoo.org> qt-3.1.0.ebuild:
+ Added opengl useflag.
15 Nov 2002; Hannes Mehnert <hannes@gentoo.org> qt-3.1.0.ebuild:
Added patch for QWidget::showMinimized() that didn't make it into the final
diff --git a/x11-libs/qt/qt-3.1.0.ebuild b/x11-libs/qt/qt-3.1.0.ebuild
index 0461cb789ce7..ceb6f9d86257 100644
--- a/x11-libs/qt/qt-3.1.0.ebuild
+++ b/x11-libs/qt/qt-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0.ebuild,v 1.2 2002/11/15 15:12:16 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.0.ebuild,v 1.3 2002/11/17 15:04:20 karltk Exp $
IUSE="cups nas postgres opengl mysql odbc gif"
@@ -25,7 +25,8 @@ DEPEND="virtual/x11
odbc? ( >=dev-db/unixODBC-2.0 )
mysql? ( >=dev-db/mysql-3.2.10 )
opengl? ( virtual/opengl virtual/glu )
- postgres? ( >=dev-db/postgresql-7.2 )"
+ postgres? ( >=dev-db/postgresql-7.2 )
+ opengl? ( virtual/opengl ) "
QTBASE=/usr/qt/3
@@ -72,6 +73,7 @@ src_compile() {
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/server"
use odbc && myconf="${myconf} -plugin-sql-odbc"
+ use opengl && myconf="${myconf} -enable-module=opengl" || myconf="${myconfig} -disable-opengl"
[ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
# avoid wasting time building things we won't install