summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-03-08 18:33:03 +0000
committerMarinus Schraal <foser@gentoo.org>2003-03-08 18:33:03 +0000
commitaa13681f3ebd369b3f66ed6ac83fd379497aab5b (patch)
tree7336e88c9b1fd0cba9f9e51d06d15bade239f255 /x11-libs
parentnew ebuild. #16448. (diff)
downloadgentoo-2-aa13681f3ebd369b3f66ed6ac83fd379497aab5b.tar.gz
gentoo-2-aa13681f3ebd369b3f66ed6ac83fd379497aab5b.tar.bz2
gentoo-2-aa13681f3ebd369b3f66ed6ac83fd379497aab5b.zip
new patch, should fix persistent locale bug
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-1.2.10-r102
-rw-r--r--x11-libs/gtk+/files/gtk+-1.2-locale_fix.patch19
-rw-r--r--x11-libs/gtk+/gtk+-1.2.10-r10.ebuild84
-rw-r--r--x11-libs/gtk+/gtk+-2.2.1.ebuild4
5 files changed, 116 insertions, 2 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 30aaf79cdcb6..68ca0d5a99cb 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.55 2003/03/04 21:34:25 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.56 2003/03/08 18:33:03 foser Exp $
+
+*gtk+-1.2.10-r10 (08 Mar 2003)
+
+ 08 Mar 2003; foser <foser@gentoo.org> gtk+-1.2.10-r10.ebuild :
+ New patch to fix locale problems that have been bugging us for a long time
+ Patch done by Stanislav Brabec <sbrabec@suse.cz>
+ Related gentoo bugs #10529, #16883
*gtk+-2.2.1 (04 Feb 2003)
diff --git a/x11-libs/gtk+/files/digest-gtk+-1.2.10-r10 b/x11-libs/gtk+/files/digest-gtk+-1.2.10-r10
new file mode 100644
index 000000000000..c7995d372331
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-1.2.10-r10
@@ -0,0 +1,2 @@
+MD5 4d5cb2fc7fb7830e4af9747a36bfce20 gtk+-1.2.10.tar.gz 2868322
+MD5 0ae8dcec20e0fa6dbc022d5eb00dc2a3 gtk+-1.2.10-r8-gentoo.diff.bz2 81223
diff --git a/x11-libs/gtk+/files/gtk+-1.2-locale_fix.patch b/x11-libs/gtk+/files/gtk+-1.2-locale_fix.patch
new file mode 100644
index 000000000000..a3fd198b6904
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-1.2-locale_fix.patch
@@ -0,0 +1,19 @@
+--- gtk/gtkrc.c.~1.40.2.17.~ 2001-07-10 20:06:35.000000000 +0200
++++ gtk/gtkrc.c 2003-03-05 16:56:10.000000000 +0100
+@@ -453,7 +453,7 @@
+
+ if (!initted)
+ {
+- char *locale = setlocale (LC_CTYPE, NULL);
++ char *locale = g_strdup (setlocale (LC_CTYPE, NULL));
+ char *p;
+
+ initted = TRUE;
+@@ -558,6 +558,7 @@
+
+ if (tmp) g_free (tmp);
+ }
++ g_free (locale);
+ }
+
+ i = 0;
diff --git a/x11-libs/gtk+/gtk+-1.2.10-r10.ebuild b/x11-libs/gtk+/gtk+-1.2.10-r10.ebuild
new file mode 100644
index 000000000000..033242ea3e45
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-1.2.10-r10.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r10.ebuild,v 1.1 2003/03/08 18:33:03 foser Exp $
+
+inherit eutils
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GIMP Toolkit"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${P}.tar.gz
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz
+ http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/gtk+-1.2.10-r8-gentoo.diff.bz2"
+
+DEPEND="virtual/x11
+ =dev-libs/glib-1.2*
+ nls? ( sys-devel/gettext
+ dev-util/intltool )"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}/..
+ bzcat ${DISTDIR}/gtk+-1.2.10-r8-gentoo.diff.bz2 | patch -p0
+
+ # locale fix by sbrabec@suse.cz
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.2-locale_fix.patch
+}
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ if [ "${DEBUGBUILD}" ]
+ then
+ myconf="${myconf} --enable-debug=yes"
+ else
+ myconf="${myconf} --enable-debug=minimum"
+ fi
+
+ econf \
+ --sysconfdir=/etc/X11 \
+ --with-xinput=xfree \
+ --with-x \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ preplib /usr
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING
+ dodoc NEWS* README* TODO
+ docinto docs
+ cd docs
+ dodoc *.txt *.gif text/*
+ dohtml -r html
+
+ #install nice, clean-looking gtk+ style
+ insinto /usr/share/themes/Gentoo/gtk
+ doins ${FILESDIR}/gtkrc
+}
+
+pkg_postinst() {
+ ewarn "Older versions added /etc/X11/gtk/gtkrc which changed settings for"
+ ewarn "all themes it seems. Please remove it manually as it will not due"
+ ewarn "to /env protection."
+ echo ""
+ einfo "The old gtkrc is available through the new Gentoo gtk theme."
+}
diff --git a/x11-libs/gtk+/gtk+-2.2.1.ebuild b/x11-libs/gtk+/gtk+-2.2.1.ebuild
index 933397d711a5..9dddfad04824 100644
--- a/x11-libs/gtk+/gtk+-2.2.1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.2.1.ebuild,v 1.9 2003/03/04 21:34:25 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.2.1.ebuild,v 1.10 2003/03/08 18:33:03 foser Exp $
inherit eutils libtool flag-o-matic
@@ -36,6 +36,8 @@ src_unpack() {
cd ${S}; epatch ${FILESDIR}/gtk+-wm.patch
# beautifying patch for disabled icons
epatch ${FILESDIR}/${P}-disable_icons_smooth_alpha.patch
+ # toolbar UI fix (http://bugzilla.gnome.org/show_bug.cgi?id=55393)
+ epatch ${FILESDIR}/${PN}-2.2-toolbar_improved_looks_fix.patch
if [ "${ARCH}" == "ppc" ]
then