summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-11-14 01:34:35 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-11-14 01:34:35 +0000
commitc71909ceb716ba2c1637585cc2cf871d3578483e (patch)
treedad788ed5c858a2dd8c32b7b8d7b89a1b1626f4c /x11-misc/pypanel/pypanel-0.9.ebuild
parentNew upstream version (diff)
downloadgentoo-2-c71909ceb716ba2c1637585cc2cf871d3578483e.tar.gz
gentoo-2-c71909ceb716ba2c1637585cc2cf871d3578483e.tar.bz2
gentoo-2-c71909ceb716ba2c1637585cc2cf871d3578483e.zip
New upstream version
Diffstat (limited to 'x11-misc/pypanel/pypanel-0.9.ebuild')
-rw-r--r--x11-misc/pypanel/pypanel-0.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/pypanel/pypanel-0.9.ebuild b/x11-misc/pypanel/pypanel-0.9.ebuild
new file mode 100644
index 000000000000..59c8429a5a50
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pypanel/pypanel-0.9.ebuild,v 1.1 2003/11/14 01:34:30 karltk Exp $
+
+DESCRIPTION="PyPanel is a lightweight panel/taskbar for X11 window managers."
+HOMEPAGE="http://pypanel.sourceforge.net"
+SRC_URI="mirror://sourceforge/pypanel/PyPanel-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=x11-base/xfree-4.3.0-r2
+ >=dev-lang/python-2.2.3-r1
+ >=dev-python/python-xlib-0.12"
+S="${WORKDIR}/PyPanel-${PV}"
+
+inherit distutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Removing offensive material
+ cp pypanelrc pypanelrc.orig
+ sed "s/%D %I:%M %p/%Y-%m-%d %H:%M/" \
+ < pypanelrc.orig > pypanelrc
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+ ewarn "If you previous ran 0.8, remove ~/.pypanelrc before starting 0.9!"
+}