summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-05-26 17:36:33 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-05-26 17:36:33 +0000
commitc98930855c5b1aa21a9fce1040ff8415b3f21a28 (patch)
treec8600af9b20f527b4164f9f8f8f5ba17d8cfd09b /x11-misc/treeline
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-c98930855c5b1aa21a9fce1040ff8415b3f21a28.tar.gz
gentoo-2-c98930855c5b1aa21a9fce1040ff8415b3f21a28.tar.bz2
gentoo-2-c98930855c5b1aa21a9fce1040ff8415b3f21a28.zip
initial import
Diffstat (limited to 'x11-misc/treeline')
-rw-r--r--x11-misc/treeline/ChangeLog9
-rw-r--r--x11-misc/treeline/Manifest2
-rw-r--r--x11-misc/treeline/files/digest-treeline-0.7.31
-rw-r--r--x11-misc/treeline/treeline-0.7.3.ebuild54
4 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/treeline/ChangeLog b/x11-misc/treeline/ChangeLog
new file mode 100644
index 000000000000..1c90eea4ae81
--- /dev/null
+++ b/x11-misc/treeline/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/treeline
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.1 2004/05/26 17:36:33 taviso Exp $
+
+*treeline-0.7.3 (26 May 2004)
+
+ 26 May 2004; Tavis Ormandy <taviso@gentoo.org> treeline-0.7.3.ebuild:
+ initial import
+
diff --git a/x11-misc/treeline/Manifest b/x11-misc/treeline/Manifest
new file mode 100644
index 000000000000..3a3b0f10189b
--- /dev/null
+++ b/x11-misc/treeline/Manifest
@@ -0,0 +1,2 @@
+MD5 b332bc328f0857b01fe33dc104101d50 treeline-0.7.3.ebuild 835
+MD5 c2791a8dd83630045f2360dc17f58c10 files/digest-treeline-0.7.3 66
diff --git a/x11-misc/treeline/files/digest-treeline-0.7.3 b/x11-misc/treeline/files/digest-treeline-0.7.3
new file mode 100644
index 000000000000..c823c7a248f0
--- /dev/null
+++ b/x11-misc/treeline/files/digest-treeline-0.7.3
@@ -0,0 +1 @@
+MD5 81f094b5bd722a97380363eeef2bc347 treeline-0.7.3.tar.gz 120085
diff --git a/x11-misc/treeline/treeline-0.7.3.ebuild b/x11-misc/treeline/treeline-0.7.3.ebuild
new file mode 100644
index 000000000000..0ce9012aaed8
--- /dev/null
+++ b/x11-misc/treeline/treeline-0.7.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-0.7.3.ebuild,v 1.1 2004/05/26 17:36:33 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="TreeLine is a structured information storage program."
+HOMEPAGE="http://www.bellz.org/treeline/"
+
+SRC_URI="http://www.bellz.org/treeline/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="spell"
+
+DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
+ || ( dev-python/pyxml dev-libs/expat )
+ dev-lang/python dev-python/PyQt
+ >=x11-libs/qt-3.3.0-r1"
+
+S=${WORKDIR}/TreeLine
+
+src_compile() {
+
+ # gah. :(
+ sed -i "s#f = open(path, 'r')#return#g" ${S}/install.py || die
+ sed -i "s#\(helpFilePath =\) None#\1 '/usr/share/doc'#g" ${S}/source/*.py || die
+ sed -i "s#\(dataFilePath =\) None#\1 '/usr/lib/treeline'#g" ${S}/source/*.py || die
+ sed -i "s#\(copyDir('icons',\) iconDir)#\1 \'${D}/usr/share/icons\')#g" ${S}/install.py || die
+
+ # optional {a,i}spell suport
+ if ! use spell; then
+ sed -i 's/\(testSpell =\) 1/\1 0/g' ${S}/install.py || {
+ ewarn "failed to disable check for spell support"
+ }
+ fi
+
+ printf '#!/bin/sh\n\nexec %s %s/%s.py $*' \
+ python /usr/lib/treeline treeline > ${T}/treeline
+}
+
+src_install() {
+ python ${S}/install.py -p ${D}/usr || die "installation script failed!"
+
+ insinto /usr/lib/treeline
+ doins ${S}/doc/README.html
+
+ dobin ${T}/treeline
+
+ # FIXME: dohtml the html file.
+ mv ${D}/usr/share/doc/${PN} ${D}/usr/share/doc/${P}
+ prepalldocs
+}