summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-16 23:23:32 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-16 23:23:32 +0000
commit37348814bb0809f605aa2a0793cdfccaed957af1 (patch)
treeb1645ac0867789a9357263222db6b7a7d1e7bb47 /x11-misc/ttmkfdir/ttmkfdir-3.0.9.ebuild
parentremoved ABOUT-NLS from dodoc since it doesn't exist (diff)
downloadgentoo-2-37348814bb0809f605aa2a0793cdfccaed957af1.tar.gz
gentoo-2-37348814bb0809f605aa2a0793cdfccaed957af1.tar.bz2
gentoo-2-37348814bb0809f605aa2a0793cdfccaed957af1.zip
new version; mark 3.0.4 stable for x86
Diffstat (limited to 'x11-misc/ttmkfdir/ttmkfdir-3.0.9.ebuild')
-rw-r--r--x11-misc/ttmkfdir/ttmkfdir-3.0.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/ttmkfdir/ttmkfdir-3.0.9.ebuild b/x11-misc/ttmkfdir/ttmkfdir-3.0.9.ebuild
new file mode 100644
index 000000000000..850621e7305b
--- /dev/null
+++ b/x11-misc/ttmkfdir/ttmkfdir-3.0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ttmkfdir-3.0.9.ebuild,v 1.1 2003/03/16 23:23:32 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A utility to create a fonts.scale file from a set of TrueType fonts"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.joerg-pommnitz.de/TrueType/xfsft.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~arm"
+
+DEPEND=">=media-libs/freetype-2.0.8
+ >=sys-devel/flex-2.5.4a-r5
+ sys-devel/libtool"
+
+src_compile() {
+ [ -z "${CXX}" ] && CXX="g++"
+
+ make CXX="${CXX}" \
+ OPTFLAGS="${CFLAGS}" DEBUG="" || die
+}
+
+src_install() {
+ exeinto /usr/X11R6/bin
+ doexe ${S}/ttmkfdir
+
+ dodoc ${S}/README
+}
+