summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-03 16:09:24 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-03 16:09:24 +0000
commit46bede6cc67dbb7a487fcb03c0309956401ad2fe (patch)
tree1bcf39b148900c40f1bbaa8312fdab667697f118 /x11-plugins/asapm
parentoops0r (diff)
downloadgentoo-2-46bede6cc67dbb7a487fcb03c0309956401ad2fe.tar.gz
gentoo-2-46bede6cc67dbb7a487fcb03c0309956401ad2fe.tar.bz2
gentoo-2-46bede6cc67dbb7a487fcb03c0309956401ad2fe.zip
moved asclock from x11-misc to x11-plugins
Diffstat (limited to 'x11-plugins/asapm')
-rw-r--r--x11-plugins/asapm/ChangeLog19
-rw-r--r--x11-plugins/asapm/asapm-2.10.ebuild31
-rw-r--r--x11-plugins/asapm/asapm-2.11.ebuild46
-rw-r--r--x11-plugins/asapm/files/asapm-2.10-gentoo.diff19
-rw-r--r--x11-plugins/asapm/files/digest-asapm-2.101
-rw-r--r--x11-plugins/asapm/files/digest-asapm-2.111
6 files changed, 117 insertions, 0 deletions
diff --git a/x11-plugins/asapm/ChangeLog b/x11-plugins/asapm/ChangeLog
new file mode 100644
index 000000000000..6fa0fa900a59
--- /dev/null
+++ b/x11-plugins/asapm/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for x11-misc/asapm
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/ChangeLog,v 1.1 2002/11/03 16:09:24 seemant Exp $
+
+*asapm-2.11 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> asapm-2.11.ebuild :
+
+ Version bump with USE dependent jpeg support
+
+*asapm-2.10 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/x11-plugins/asapm/asapm-2.10.ebuild b/x11-plugins/asapm/asapm-2.10.ebuild
new file mode 100644
index 000000000000..5017c2792c92
--- /dev/null
+++ b/x11-plugins/asapm/asapm-2.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/asapm-2.10.ebuild,v 1.1 2002/11/03 16:09:24 seemant Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="APM monitor for AfterStep"
+
+SRC_URI="http://www.tigr.net/afterstep/download/asapm/asapm-2.10.tar.gz"
+
+HOMEPAGE="http://www.tigr.net/afterstep/list.pl"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/glibc virtual/x11"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ emake || die
+}
+
+src_install () {
+
+ dodir usr/bin
+ dodir usr/share/man/man1
+
+ make prefix=${D} install || die
+}
+
diff --git a/x11-plugins/asapm/asapm-2.11.ebuild b/x11-plugins/asapm/asapm-2.11.ebuild
new file mode 100644
index 000000000000..e77aaafabe31
--- /dev/null
+++ b/x11-plugins/asapm/asapm-2.11.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/asapm-2.11.ebuild,v 1.1 2002/11/03 16:09:24 seemant Exp $
+
+IUSE="jpeg"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="APM monitor for AfterStep"
+SRC_URI="http://www.tigr.net/afterstep/download/asapm/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net/afterstep/list.pl"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/x11
+ jpeg? ( media-libs/jpeg )"
+
+src_compile() {
+
+ local myconf
+
+ use jpeg \
+ && myconf="${myconf} --enable-jpeg" \
+ || myconf="${myconf} --disable-jpeg"
+
+ ./configure \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ emake || die
+}
+
+src_install () {
+
+ dodir usr/bin
+ dodir usr/share/man/man1
+
+ make \
+ AFTER_BIN_DIR=${D}/usr/bin \
+ AFTER_MAN_DIR=${D}/usr/share/man/man1 \
+ install || die
+}
diff --git a/x11-plugins/asapm/files/asapm-2.10-gentoo.diff b/x11-plugins/asapm/files/asapm-2.10-gentoo.diff
new file mode 100644
index 000000000000..991a303c13aa
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-2.10-gentoo.diff
@@ -0,0 +1,19 @@
+--- Makefile.orig Tue Sep 25 23:36:44 2001
++++ Makefile Tue Sep 25 23:37:25 2001
+@@ -50,10 +50,12 @@
+ LIBS_AFTERSTEP =
+ LIBRARIES = $(LIBS_X) $(LIBS_XPM) $(LIBS_JPEG) $(LIBS_XEXTS) $(LIBS_AFTERSTEP)
+
+-AFTER_BIN_DIR = /usr/bin
+-AFTER_MAN_DIR = /usr/share/man/man1
+-AFTER_DOC_DIR = /usr/share/afterstep/doc
+-AFTER_SHAREDIR = /usr/share/afterstep
++
++AFTER_BIN_DIR = $(prefix)/usr/bin
++AFTER_MAN_DIR = $(prefix)/usr/share/man/man1
++AFTER_DOC_DIR = $(prefix)/usr/share/afterstep/doc
++AFTER_SHAREDIR = $(prefix)/usr/share/afterstep
++
+ GNUSTEP = ~/GNUstep
+ GNUSTEPLIB = ~/GNUstep/Library
+ AFTER_DIR = ~/GNUstep/Library/AfterStep
diff --git a/x11-plugins/asapm/files/digest-asapm-2.10 b/x11-plugins/asapm/files/digest-asapm-2.10
new file mode 100644
index 000000000000..c1d13d709f0b
--- /dev/null
+++ b/x11-plugins/asapm/files/digest-asapm-2.10
@@ -0,0 +1 @@
+MD5 5ac6d75297e430a7bdd0bc782035ef87 asapm-2.10.tar.gz 51304
diff --git a/x11-plugins/asapm/files/digest-asapm-2.11 b/x11-plugins/asapm/files/digest-asapm-2.11
new file mode 100644
index 000000000000..c7b2b184e83d
--- /dev/null
+++ b/x11-plugins/asapm/files/digest-asapm-2.11
@@ -0,0 +1 @@
+MD5 91521ada646faeae93df385b8ca9c5f4 asapm-2.11.tar.gz 58729