summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-31 14:48:45 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-31 14:48:45 +0000
commitcde5ed9d2f25adebf01a3118f95ce8bf479f6627 (patch)
tree1a0c83e669362798dd92705b70b0a57f50df71ee /x11-plugins/gkrellflynn
parentStable for arm, wrt bug #481894 (diff)
downloadgentoo-2-cde5ed9d2f25adebf01a3118f95ce8bf479f6627.tar.gz
gentoo-2-cde5ed9d2f25adebf01a3118f95ce8bf479f6627.tar.bz2
gentoo-2-cde5ed9d2f25adebf01a3118f95ce8bf479f6627.zip
Fix gcc-4.7 building (#427414), respect LDFLAGS/CFLAGS (#334813)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-plugins/gkrellflynn')
-rw-r--r--x11-plugins/gkrellflynn/ChangeLog6
-rw-r--r--x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch37
-rw-r--r--x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild18
3 files changed, 55 insertions, 6 deletions
diff --git a/x11-plugins/gkrellflynn/ChangeLog b/x11-plugins/gkrellflynn/ChangeLog
index 94be8c0421cf..ce3ab1a5200d 100644
--- a/x11-plugins/gkrellflynn/ChangeLog
+++ b/x11-plugins/gkrellflynn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gkrellflynn
# Copyright 2002-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellflynn/ChangeLog,v 1.26 2013/06/01 11:30:12 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellflynn/ChangeLog,v 1.27 2013/08/31 14:48:45 pacho Exp $
+
+ 31 Aug 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gkrellflynn-0.8-makefile.patch, gkrellflynn-0.8.ebuild:
+ Fix gcc-4.7 building (#427414), respect LDFLAGS/CFLAGS (#334813)
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #144305
diff --git a/x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch b/x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch
new file mode 100644
index 000000000000..0b539fa6635f
--- /dev/null
+++ b/x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch
@@ -0,0 +1,37 @@
+--- Makefile 2002-05-07 10:04:49.000000000 +0200
++++ Makefile_new 2013-03-12 21:10:15.888656809 +0100
+@@ -3,11 +3,10 @@
+ #
+ # updated for gkrellm2.0
+
+-CC = gcc
+-CFLAGS = -c -O -Wall -fPIC `${EXTRACONF}`
++CC = $(CC)
++INCLUDE = -c -fPIC `${EXTRACONF}`
+
+-LD = $(CC)
+-LDFLAGS = -shared -Wl -o
++LDFLAGS = $(LDFLAGS)
+ INCPATH = -I.
+ INCPATH += ${GKRELL_INC}
+
+@@ -25,10 +24,10 @@
+ (make GKRELL_INC=-DGKRELLM EXTRACONF="gtk-config --cflags;imlib-config --cflags-gdk" ${TARGET})
+
+ gkrellm2:
+- (make GKRELL_INC=-DGKRELLM2 EXTRACONF="pkg-config --cflags gtk+-2.0 gthread-2.0" ${TARGET})
++ ($(MAKE) GKRELL_INC=-DGKRELLM2 EXTRACONF="pkg-config --cflags gtk+-2.0 gthread-2.0" ${TARGET})
+
+ ${TARGET}: ${OBJS}
+- ${LD} ${DEBUG} ${LDFLAGS} ${TARGET} ${OBJS}
++ ${CC} -shared ${LDFLAGS} ${CFLAGS} -o ${TARGET} ${OBJS}
+
+ clean:
+ rm -f ${OBJS}
+@@ -47,5 +46,5 @@
+ ./install-sub.sh ${TARGET} gkrellm2
+
+ %.o : %.c
+- ${CC} ${CFLAGS} $(INCPATH) -o $@ $<
++ ${CC} ${CFLAGS} $(INCLUDE) ${LDFLAGS} $(INCPATH) -o $@ $<
+
diff --git a/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild b/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild
index 985719821474..b552ba883920 100644
--- a/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild
+++ b/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild
@@ -1,17 +1,25 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild,v 1.9 2008/11/18 14:06:53 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild,v 1.10 2013/08/31 14:48:45 pacho Exp $
-inherit gkrellm-plugin
+EAPI="5"
+inherit eutils gkrellm-plugin toolchain-funcs
-IUSE=""
HOMEPAGE="http://bax.comlab.uni-rostock.de/en/projects/flynn.html"
SRC_URI="http://bax.comlab.uni-rostock.de/fileadmin/downloads/${P}.tar.gz"
DESCRIPTION="A funny GKrellM2 load monitor (for Doom(tm) fans)"
KEYWORDS="alpha amd64 ppc sparc x86"
SLOT="0"
LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
src_compile() {
- make gkrellm2
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" gkrellm2
}