summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-08-31 19:22:09 +0000
committerDan Armak <danarmak@gentoo.org>2002-08-31 19:22:09 +0000
commit754b256d769b7dd364da85563d2a4390bccef8dd (patch)
tree9dde8674dd3677f8971aa9edef5277c7181cc2a7 /x11-themes
parentFix bug #5901 - use kde-functions.eclass to determine the proper insall locat... (diff)
downloadgentoo-2-754b256d769b7dd364da85563d2a4390bccef8dd.tar.gz
gentoo-2-754b256d769b7dd364da85563d2a4390bccef8dd.tar.bz2
gentoo-2-754b256d769b7dd364da85563d2a4390bccef8dd.zip
Fix bug #5901 - use kde-functions.eclass to determine the proper install location; depend on kdelibs
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/ikons/files/digest-ikons-0.5.8-r1 (renamed from x11-themes/ikons/files/digest-ikons-0.5.8)0
-rw-r--r--x11-themes/ikons/ikons-0.5.8-r1.ebuild (renamed from x11-themes/ikons/ikons-0.5.8.ebuild)19
2 files changed, 8 insertions, 11 deletions
diff --git a/x11-themes/ikons/files/digest-ikons-0.5.8 b/x11-themes/ikons/files/digest-ikons-0.5.8-r1
index c6c400f0b95f..c6c400f0b95f 100644
--- a/x11-themes/ikons/files/digest-ikons-0.5.8
+++ b/x11-themes/ikons/files/digest-ikons-0.5.8-r1
diff --git a/x11-themes/ikons/ikons-0.5.8.ebuild b/x11-themes/ikons/ikons-0.5.8-r1.ebuild
index 868c6db5ac17..c243d2c759cc 100644
--- a/x11-themes/ikons/ikons-0.5.8.ebuild
+++ b/x11-themes/ikons/ikons-0.5.8-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/ikons/ikons-0.5.8.ebuild,v 1.1 2002/08/30 08:06:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/ikons/ikons-0.5.8-r1.ebuild,v 1.1 2002/08/31 19:22:09 danarmak Exp $
+inherit kde
+set-kdedir 3
S="${WORKDIR}/iKons_058"
DESCRIPTION="iKons iconset for KDE 2.x"
@@ -10,6 +12,7 @@ KEYWORDS="x86 sparc sparc64"
SLOT="0"
LICENSE="as-is"
+
src_compile() {
return 1
@@ -18,14 +21,8 @@ src_compile() {
src_install(){
cd ${S}
- if [ -d ${KDE2DIR} ] ; then
- mkdir -p ${D}/${KDE2DIR}/share/icons/
- cp -rf ${S} ${D}/${KDE2DIR}/share/icons/iKons_058
- fi
-
- if [ -d ${KDE3DIR} ] ; then
- mkdir -p ${D}/${KDE3DIR}/share/icons/
- cp -rf ${S} ${D}/${KDE3DIR}/share/icons/iKons_058
- fi
-
+
+ dodir $PREFIX/share/icons
+ cp -rf ${S} ${D}/${PREFIX}/share/icons/iKons_058
+
}