summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-11-29 14:08:31 +0000
committerJim Ramsay <lack@gentoo.org>2011-11-29 14:08:31 +0000
commitfe46d2b1dae317af7518391d9ef3b9f444f7d43f (patch)
tree5f698fa56379c3bb038716642374ae54afec2cd4 /x11-wm/fluxbox
parentApply upstream patches to fix pkgconfig file and arches that use 64-bit doubl... (diff)
downloadgentoo-2-fe46d2b1dae317af7518391d9ef3b9f444f7d43f.tar.gz
gentoo-2-fe46d2b1dae317af7518391d9ef3b9f444f7d43f.tar.bz2
gentoo-2-fe46d2b1dae317af7518391d9ef3b9f444f7d43f.zip
Version bump: 1.3.2 is released, now with true ARGB (Xrender transparency)
support. Also fixes bug #388569: Removing 'gnome' USE flag as there is no corresponding option in the application any more. (Portage version: 2.1.10.31/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/fluxbox')
-rw-r--r--x11-wm/fluxbox/ChangeLog13
-rw-r--r--x11-wm/fluxbox/fluxbox-1.3.2.ebuild103
-rw-r--r--x11-wm/fluxbox/fluxbox-9999.ebuild20
3 files changed, 123 insertions, 13 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index 3dea856df6c3..f866d3929a7d 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for x11-wm/fluxbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.296 2011/08/20 16:03:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.297 2011/11/29 14:08:31 lack Exp $
+
+*fluxbox-1.3.2 (29 Nov 2011)
+
+ 29 Nov 2011; Jim Ramsay <jim_ramsay@gentoo.org> +fluxbox-1.3.2.ebuild,
+ fluxbox-9999.ebuild:
+ Version bump: 1.3.2 is released, now with true ARGB (Xrender transparency)
+ support.
+
+ Also fixes bug #388569: Removing 'gnome' USE flag as there is no
+ corresponding
+ option in the application any more.
20 Aug 2011; Jeroen Roovers <jer@gentoo.org> fluxbox-1.3.1.ebuild:
Stable for HPPA (bug #375013).
diff --git a/x11-wm/fluxbox/fluxbox-1.3.2.ebuild b/x11-wm/fluxbox/fluxbox-1.3.2.ebuild
new file mode 100644
index 000000000000..d15c9d8d4247
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-1.3.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.2.ebuild,v 1.1 2011/11/29 14:08:31 lack Exp $
+
+EAPI=4
+inherit eutils prefix
+
+IUSE="nls xinerama bidi +truetype +imlib +slit +toolbar vim-syntax"
+
+DESCRIPTION="Fluxbox is an X11 window manager featuring tabs and an iconbar"
+
+SRC_URI="mirror://sourceforge/fluxbox/${P}.tar.bz2"
+HOMEPAGE="http://www.fluxbox.org"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender
+ || ( x11-misc/gkmessage x11-apps/xmessage )
+ xinerama? ( x11-libs/libXinerama )
+ truetype? ( media-libs/freetype )
+ bidi? ( dev-libs/fribidi )
+ imlib? ( >=media-libs/imlib2-1.2.0[X] )
+ vim-syntax? ( app-vim/fluxbox-syntax )
+ !!<x11-themes/fluxbox-styles-fluxmod-20040809-r1
+ !!<=x11-misc/fluxconf-0.9.9
+ !!<=x11-misc/fbdesk-1.2.1"
+DEPEND="nls? ( sys-devel/gettext )
+ x11-proto/xextproto
+ ${RDEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ # We need to be able to include directories rather than just plain
+ # files in menu [include] items. This patch will allow us to do clever
+ # things with style ebuilds.
+ epatch "${FILESDIR}/gentoo_style_location-1.1.x.patch"
+ eprefixify util/fluxbox-generate_menu.in
+
+ epatch "${FILESDIR}"/osx-has-otool.patch
+
+ # Add in the Gentoo -r number to fluxbox -version output.
+ if [[ "${PR}" == "r0" ]] ; then
+ suffix="gentoo"
+ else
+ suffix="gentoo-${PR}"
+ fi
+ sed -i \
+ -e "s~\(__fluxbox_version .@VERSION@\)~\1-${suffix}~" \
+ version.h.in || die "version sed failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable truetype xft) \
+ $(use_enable imlib imlib2) \
+ $(use_enable bidi fribidi ) \
+ $(use_enable slit ) \
+ $(use_enable toolbar ) \
+ --sysconfdir="${EPREFIX}"/etc/X11/${PN} \
+ --with-style="${EPREFIX}"/usr/share/fluxbox/styles/Emerge \
+ ${myconf}
+}
+
+src_compile() {
+ default
+
+ ebegin "Creating a menu file (may take a while)"
+ mkdir -p "${T}/home/.fluxbox" || die "mkdir home failed"
+ MENUFILENAME="${S}/data/menu" MENUTITLE="Fluxbox ${PV}" \
+ CHECKINIT="no. go away." HOME="${T}/home" \
+ "${S}/util/fluxbox-generate_menu" -is -ds \
+ || die "menu generation failed"
+ eend $?
+}
+
+src_install() {
+ dodir /usr/share/fluxbox
+ emake DESTDIR="${D}" STRIP="" install
+ dodoc README* AUTHORS TODO* ChangeLog NEWS
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}/${PN}.xsession" fluxbox
+
+ dodir /usr/share/fluxbox/menu.d
+
+ # Styles menu framework
+ dodir /usr/share/fluxbox/menu.d/styles
+ insinto /usr/share/fluxbox/menu.d/styles
+ doins "${FILESDIR}/styles-menu-fluxbox"
+ doins "${FILESDIR}/styles-menu-commonbox"
+ doins "${FILESDIR}/styles-menu-user"
+}
diff --git a/x11-wm/fluxbox/fluxbox-9999.ebuild b/x11-wm/fluxbox/fluxbox-9999.ebuild
index c4d9ce2e39f6..7ca6a6012a4e 100644
--- a/x11-wm/fluxbox/fluxbox-9999.ebuild
+++ b/x11-wm/fluxbox/fluxbox-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild,v 1.9 2011/07/14 03:05:22 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild,v 1.10 2011/11/29 14:08:31 lack Exp $
-EAPI=3
+EAPI=4
inherit eutils git-2 prefix
-IUSE="nls xinerama bidi +truetype gnome +imlib +slit +toolbar vim-syntax"
+IUSE="nls xinerama bidi +truetype +imlib +slit +toolbar vim-syntax"
DESCRIPTION="Fluxbox is an X11 window manager featuring tabs and an iconbar"
@@ -13,16 +13,13 @@ EGIT_REPO_URI="git://git.fluxbox.org/fluxbox.git"
SRC_URI=""
HOMEPAGE="http://www.fluxbox.org"
-# Please note that USE="gnome" simply adds support for the respective
-# protocol, and does not depend on external libraries. It does, however,
-# make the binary a fair bit bigger, so we don't want to turn it on unless
-# the user actually wants them.
-
RDEPEND="x11-libs/libXpm
x11-libs/libXrandr
- xinerama? ( x11-libs/libXinerama )
- x11-apps/xmessage
+ x11-libs/libXext
x11-libs/libXft
+ x11-libs/libXrender
+ || ( x11-misc/gkmessage x11-apps/xmessage )
+ xinerama? ( x11-libs/libXinerama )
truetype? ( media-libs/freetype )
bidi? ( dev-libs/fribidi )
imlib? ( >=media-libs/imlib2-1.2.0[X] )
@@ -32,7 +29,6 @@ RDEPEND="x11-libs/libXpm
!!<=x11-misc/fbdesk-1.2.1"
DEPEND="nls? ( sys-devel/gettext )
x11-proto/xextproto
- xinerama? ( x11-proto/xineramaproto )
${RDEPEND}"
SLOT="0"
@@ -61,10 +57,10 @@ src_prepare() {
src_configure() {
econf \
+ --disable-dependency-tracking \
$(use_enable nls) \
$(use_enable xinerama) \
$(use_enable truetype xft) \
- $(use_enable gnome) \
$(use_enable imlib imlib2) \
$(use_enable slit ) \
$(use_enable toolbar ) \