summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-11-24 22:47:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-11-24 22:47:39 +0000
commit71b654812859ca8ad4aa0cbab350655646aa47f8 (patch)
tree530a5b8a237b431d348074e9901a147c8af41956 /xfce-extra
parentAdd ~x86-fbsd (diff)
downloadgentoo-2-71b654812859ca8ad4aa0cbab350655646aa47f8.tar.gz
gentoo-2-71b654812859ca8ad4aa0cbab350655646aa47f8.tar.bz2
gentoo-2-71b654812859ca8ad4aa0cbab350655646aa47f8.zip
Use Debian patchset to port from obsolete thunar-vfs layer to libgio-2.0.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-places-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0-r1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-places-plugin/ChangeLog b/xfce-extra/xfce4-places-plugin/ChangeLog
index f06bf6792e3b..3bb2542784b6 100644
--- a/xfce-extra/xfce4-places-plugin/ChangeLog
+++ b/xfce-extra/xfce4-places-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-places-plugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/ChangeLog,v 1.13 2011/05/31 11:24:05 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/ChangeLog,v 1.14 2011/11/24 22:47:39 ssuominen Exp $
+
+*xfce4-places-plugin-1.2.0-r1 (24 Nov 2011)
+
+ 24 Nov 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-places-plugin-1.2.0-r1.ebuild:
+ Use Debian patchset to port from obsolete thunar-vfs layer to libgio-2.0.
31 May 2011; Christoph Mende <angelos@gentoo.org>
xfce4-places-plugin-1.2.0.ebuild,
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0-r1.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..78184a1abe44
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0-r1.ebuild,v 1.1 2011/11/24 22:47:39 ssuominen Exp $
+
+EAPI=4
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="Places menu plug-in for panel, like GNOME's"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/1.2/${P}.tar.bz2
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV}-3.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug libnotify"
+
+RDEPEND=">=dev-libs/glib-2.22
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/exo-0.6
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=patch EPATCH_SOURCE="${WORKDIR}"/debian/patches epatch
+ xfconf_src_prepare
+}