summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/alsa-lib/ChangeLog18
-rw-r--r--media-libs/alsa-lib/alsa-lib-0.9.0.1_beta10.ebuild70
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-0.9.0.1_beta101
3 files changed, 88 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 3af639b10ae4..4612307c912c 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.1 2002/02/01 21:53:30 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.2 2002/02/04 04:50:32 tod Exp $
+
+*alsa-lib-0.9.0.1_beta10 (3 Feb 2002)
+
+ 3 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog :
+
+ Upgraded version to latest beta.
+ The issue below seems to be fixable by creating a link in the alsa-lib
+ ebuild from libasound.so.2 to libasound.so.1, but I'm leaving the warning
+ until further testing is done.
+ ##WARNING## Upgrading to this version will require massive recompiling
+ of pretty much everything linked against sound. libasound.so.1 is
+ no longer provided in the package, it is now libasound.so.2. Sound
+ apps will be broken until recompiled against the new lib. For example,
+ if you use the Gnome Desktop, you will have to recompile almost everything
+ just to start it up. Good news is you don't have to upgrade now if you
+ don't want to. Bad news is that you will eventually.
*alsa-lib-0.5.10b (1 Feb 2002)
diff --git a/media-libs/alsa-lib/alsa-lib-0.9.0.1_beta10.ebuild b/media-libs/alsa-lib/alsa-lib-0.9.0.1_beta10.ebuild
new file mode 100644
index 000000000000..40ff49c78eed
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-0.9.0.1_beta10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-0.5.10b.ebuild,v 1.1 2001/10/30 05:04:55 lordjoe Exp
+
+######################## Begin version munge #########################
+#This alsa version appends a alphabetic character to the beta version.
+#Portage doesn't seem to play well with this type of tarball versioning
+#Rather than ignore this in the ebuild version, I have encoded the
+#alphabetic beta suffix as an extra number suffix on the main version,
+#i.e., alsa-lib-0.9.0beta10a --> alsa-lib-0.9.0.1_beta10
+#If subsequent alsa-0.9.0beta's are released, this ebuild should be
+#version independent, i.e alsa-lib-0.9.0beta10b --> alsa-lib-0.9.0.2_beta10
+#just requires a copy of this ebuild to the new name. If alsa releases
+#version 1.0, this silliness can end.
+#This is probably overkill, but it was fun :)
+
+#Transform P to match tarball version
+#Grab the last revision number,
+#"bs" is short for "beta suffix", not what you're thinking :)
+bs=${PV%_beta*} #wack off _beta*
+t=${bs##*.} #wack off first three numbers, save this for later
+
+#Transform to ASCII octal number of tarball beta revision suffix
+let "a=141" #The octal number for ASCII lowercase "a"
+let "bs=$t+$a-1"
+bs=$( echo -e "\\$bs" ) #convert to character
+
+MYPV="${PV/.${t}_beta/beta}${bs}"
+MYP="${PN}-${MYPV}"
+
+######################## End version Munge ##########################
+
+S=${WORKDIR}/${MYP}
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/lib/${MYP}.tar.bz2"
+
+HOMEPAGE="http://www.alsa-project.org/"
+
+DEPEND="virtual/glibc
+ =media-sound/alsa-driver-0.9.0_beta10"
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ #This alsa version does not provide libasound.so.1
+ #Without this library just about everything even remotely
+ #linked to previous versions of alsa-lib will break.
+ #Fortunately, libasound.so.2 seems to be backwards
+ #compatible with libasound.so.2 and a simple link
+ #fixes the problem (fingers crossed)
+ dosym /usr/lib/libasound.so.2 /usr/lib/libasound.so.1
+
+ dodoc ChangeLog COPYING TODO
+
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-0.9.0.1_beta10 b/media-libs/alsa-lib/files/digest-alsa-lib-0.9.0.1_beta10
new file mode 100644
index 000000000000..f8fc23e9b100
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-0.9.0.1_beta10
@@ -0,0 +1 @@
+MD5 27215f1d641f2efbdeab72cfd906c153 alsa-lib-0.9.0beta10a.tar.bz2 363818