summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/xine-lib/ChangeLog5
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 3740826f9890..1c8834ae51fd 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.183 2005/01/03 19:46:47 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.184 2005/01/03 20:54:42 chriswhite Exp $
+
+ 04 Jan 2005; Chris White <chriswhite@gentoo.org> xine-lib-1_rc8-r1.ebuild:
+ Fixing xv stuff in -r1 as well.
04 Jan 2005; Chris White <chriswhite@gentoo.org>
+files/xine-lib-configure.ac.patch, xine-lib-1.0.ebuild:
diff --git a/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild b/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild
index b890d32e7e1d..fd1436589d2f 100644
--- a/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild,v 1.13 2005/01/02 10:41:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc8-r1.ebuild,v 1.14 2005/01/03 20:54:42 chriswhite Exp $
inherit eutils flag-o-matic gcc libtool
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/xine/${PN}-${PV/_/-}${MY_PKG_SUFFIX}.tar.gz"
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86"
-IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa gnome sdl speex theora ipv6 altivec xv"
+IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa gnome sdl speex theora ipv6 altivec xv pic"
RDEPEND="oggvorbis? ( media-libs/libvorbis )
!amd64? ( X? ( virtual/x11 ) )
@@ -63,10 +63,17 @@ src_unpack() {
# fixes bad X11 directories
epatch ${FILESDIR}/${PN}-x11.patch
+ # fixes bad xv checking
+ epatch ${FILESDIR}/${PN}-configure.ac.patch
+
# Fix building on amd64, #49569
#use amd64 && epatch ${FILESDIR}/configure-64bit-define.patch
use pic && epatch ${FILESDIR}/${PN}-1_rc7-pic.patch
+ if use pic && use x86
+ then
+ epatch ${FILESDIR}/${PN}-hardened-mmx.patch
+ fi
# Fix detection of hppa2.0 and hppa1.1 CHOST
use hppa && sed -e 's/hppa-/hppa*-linux-/' -i ${S}/configure.ac