summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/pv/pv-0.8.1.ebuild12
-rw-r--r--app-misc/regex-markup/regex-markup-0.9.0.ebuild22
-rw-r--r--app-misc/regionset/regionset-0.1.ebuild9
-rw-r--r--app-misc/ringtonetools/ringtonetools-2.18.ebuild19
-rw-r--r--app-misc/rio/rio-1.0.7.ebuild17
-rw-r--r--app-misc/rio500/rio500-0.7-r1.ebuild10
-rw-r--r--app-misc/rio500/rio500-0.7-r2.ebuild10
-rw-r--r--app-misc/rioutil/rioutil-1.4.2b.ebuild11
-rw-r--r--app-misc/rioutil/rioutil-1.4.4.ebuild14
-rw-r--r--app-misc/rl/rl-0.2.2.ebuild11
-rw-r--r--app-misc/rlwrap/rlwrap-0.16.ebuild4
-rw-r--r--app-misc/rolo/rolo-011.ebuild11
-rw-r--r--app-misc/scmxx/scmxx-0.6.3.7.ebuild15
-rw-r--r--app-misc/scmxx/scmxx-0.6.4.ebuild15
-rw-r--r--app-misc/screen/screen-4.0.2.ebuild4
-rw-r--r--app-misc/secure-delete/secure-delete-3.0.ebuild11
-rw-r--r--app-misc/sl/sl-3.03.ebuild19
-rw-r--r--app-misc/slmon/slmon-0.5.12.ebuild9
-rw-r--r--app-misc/smtm/smtm-1.4.0.ebuild9
19 files changed, 97 insertions, 135 deletions
diff --git a/app-misc/pv/pv-0.8.1.ebuild b/app-misc/pv/pv-0.8.1.ebuild
index b1aabbe5c912..93c47aaece39 100644
--- a/app-misc/pv/pv-0.8.1.ebuild
+++ b/app-misc/pv/pv-0.8.1.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pv/pv-0.8.1.ebuild,v 1.4 2004/06/24 22:29:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pv/pv-0.8.1.ebuild,v 1.5 2004/06/28 04:08:59 vapier Exp $
DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
SRC_URI="mirror://sourceforge/pipeviewer/${P}.tar.gz"
+
LICENSE="Artistic"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
-DEPEND="virtual/glibc"
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
-}
+DEPEND="virtual/libc"
+
src_install() {
make DESTDIR=${D} UNINSTALL=/bin/true install || die "install failed"
}
diff --git a/app-misc/regex-markup/regex-markup-0.9.0.ebuild b/app-misc/regex-markup/regex-markup-0.9.0.ebuild
index cca138e87683..951a2ac841c3 100644
--- a/app-misc/regex-markup/regex-markup-0.9.0.ebuild
+++ b/app-misc/regex-markup/regex-markup-0.9.0.ebuild
@@ -1,28 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/regex-markup-0.9.0.ebuild,v 1.3 2004/06/24 22:29:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/regex-markup/regex-markup-0.9.0.ebuild,v 1.4 2004/06/28 04:09:21 vapier Exp $
DESCRIPTION="A tool to color syslog files as well"
-SRC_URI="http://www.student.lu.se/~nbi98oli/src/${P}.tar.gz"
HOMEPAGE="http://www.student.lu.se/~nbi98oli"
+SRC_URI="http://www.student.lu.se/~nbi98oli/src/${P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
-RDEPEND=""
IUSE=""
-S="${WORKDIR}/${P}"
-
-src_compile()
-{
- econf || die
- emake || die
-}
+DEPEND="virtual/libc"
+RDEPEND=""
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}
diff --git a/app-misc/regionset/regionset-0.1.ebuild b/app-misc/regionset/regionset-0.1.ebuild
index 6b8c8f967eb3..300c0f6a8a97 100644
--- a/app-misc/regionset/regionset-0.1.ebuild
+++ b/app-misc/regionset/regionset-0.1.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/regionset/regionset-0.1.ebuild,v 1.3 2004/06/24 22:30:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/regionset/regionset-0.1.ebuild,v 1.4 2004/06/28 04:09:38 vapier Exp $
DESCRIPTION="Sets the region on DVD drives"
HOMEPAGE="http://linvdr.org/projects/regionset/"
SRC_URI="http://linvdr.org/download/regionset/${P}.tar.gz"
-IUSE=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc"
+IUSE=""
src_compile() {
emake all || die
}
src_install() {
- dosbin regionset
- dodoc ChangeLog README COPYING
+ dosbin regionset || die
+ dodoc ChangeLog README
}
pkg_postinst() {
@@ -30,4 +30,3 @@ pkg_postinst() {
ewarn "When you use regionset, you MUST have a cd or dvd in the drive"
ewarn "otherwise nasty things will happen to your drive's firmware."
}
-
diff --git a/app-misc/ringtonetools/ringtonetools-2.18.ebuild b/app-misc/ringtonetools/ringtonetools-2.18.ebuild
index dd5e69f268bb..d6864f57ec5d 100644
--- a/app-misc/ringtonetools/ringtonetools-2.18.ebuild
+++ b/app-misc/ringtonetools/ringtonetools-2.18.ebuild
@@ -1,24 +1,25 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ringtonetools/ringtonetools-2.18.ebuild,v 1.3 2004/06/24 22:30:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ringtonetools/ringtonetools-2.18.ebuild,v 1.4 2004/06/28 04:09:54 vapier Exp $
DESCRIPTION="Ringtone Tools is a program for creating ringtones and logos for mobile phones"
HOMEPAGE="http://ringtonetools.mikekohn.net/"
SRC_URI="http://www.mikekohn.com/ringtonetools/${P}.tar.gz"
-DEPEND="virtual/glibc"
-IUSE=""
-SLOT="0"
+
LICENSE="ringtonetools"
+SLOT="0"
KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/libc"
src_compile() {
- emake || die
+ emake FLAGS="${CFLAGS}" || die
}
src_install() {
- exeinto /usr/bin
- doexe ringtonetools
- insinto /usr/share/${P}
- doins samples/*
+ dobin ringtonetools || die
dodoc docs/*
+ docinto samples
+ dodoc samples/*
}
diff --git a/app-misc/rio/rio-1.0.7.ebuild b/app-misc/rio/rio-1.0.7.ebuild
index d49f9db51720..0a8e1613e7ff 100644
--- a/app-misc/rio/rio-1.0.7.ebuild
+++ b/app-misc/rio/rio-1.0.7.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7.ebuild,v 1.7 2004/06/24 22:30:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio/rio-1.0.7.ebuild,v 1.8 2004/06/28 04:10:11 vapier Exp $
DESCRIPTION="Utility for the Diamond Rio 300 portable MP3 player"
-SRC_URI="http://www.world.co.uk/sba/${PN}007.tgz"
HOMEPAGE="http://www.world.co.uk/sba/rio.html"
+SRC_URI="http://www.world.co.uk/sba/${PN}007.tgz"
-SLOT="0"
KEYWORDS="x86"
-IUSE=""
+SLOT="0"
LICENSE="GPL-2"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
RDEPEND=""
-UNPACKDIR=rio107
-
S=${WORKDIR}/${UNPACKDIR}
src_compile() {
@@ -23,13 +21,10 @@ src_compile() {
}
src_install() {
- into /usr
- dobin rio
+ dobin rio || die
dodoc CREDITS README gpl.txt playlist.txt rio.txt
}
pkg_postinst() {
- einfo
einfo "Warning! The /usr/bin/rio binary is installed SUID/GUID root."
- einfo
}
diff --git a/app-misc/rio500/rio500-0.7-r1.ebuild b/app-misc/rio500/rio500-0.7-r1.ebuild
index 606566ac86bf..2ad382971a41 100644
--- a/app-misc/rio500/rio500-0.7-r1.ebuild
+++ b/app-misc/rio500/rio500-0.7-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio500/rio500-0.7-r1.ebuild,v 1.13 2004/06/24 22:30:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio500/rio500-0.7-r1.ebuild,v 1.14 2004/06/28 04:10:27 vapier Exp $
DESCRIPTION="Command line tools for transfering mp3s to and from a Rio500"
+HOMEPAGE="http://rio500.sourceforge.net/"
SRC_URI="mirror://sourceforge/rio500/${P}.tar.gz"
-HOMEPAGE="http://rio500.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE=""
@@ -22,10 +22,10 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
einstall \
datadir=${D}/usr/share/rio500 || die
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ dodoc AUTHORS ChangeLog NEWS README TODO
dodoc fonts/Readme.txt
}
diff --git a/app-misc/rio500/rio500-0.7-r2.ebuild b/app-misc/rio500/rio500-0.7-r2.ebuild
index 51b49c019d0f..a5cc4c8828af 100644
--- a/app-misc/rio500/rio500-0.7-r2.ebuild
+++ b/app-misc/rio500/rio500-0.7-r2.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio500/rio500-0.7-r2.ebuild,v 1.5 2004/06/24 22:30:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio500/rio500-0.7-r2.ebuild,v 1.6 2004/06/28 04:10:27 vapier Exp $
DESCRIPTION="Command line tools for transfering mp3s to and from a Rio500"
+HOMEPAGE="http://rio500.sourceforge.net/"
SRC_URI="mirror://sourceforge/rio500/${P}.tar.gz"
-HOMEPAGE="http://rio500.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE=""
@@ -22,7 +22,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
einstall \
datadir=${D}/usr/share/rio500 || die
@@ -30,6 +30,6 @@ src_install () {
#installed with rio500
rm ${D}/usr/include/getopt.h 2>/dev/null
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ dodoc AUTHORS ChangeLog NEWS README TODO
dodoc fonts/Readme.txt
}
diff --git a/app-misc/rioutil/rioutil-1.4.2b.ebuild b/app-misc/rioutil/rioutil-1.4.2b.ebuild
index e39bca68ab1e..422c9fcf151f 100644
--- a/app-misc/rioutil/rioutil-1.4.2b.ebuild
+++ b/app-misc/rioutil/rioutil-1.4.2b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.2b.ebuild,v 1.6 2004/06/24 22:30:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.2b.ebuild,v 1.7 2004/06/28 04:10:47 vapier Exp $
DESCRIPTION="Command line tools for transfering mp3s to and from a Rio 600, 800, and Nike PSA/Play"
HOMEPAGE="http://rioutil.sourceforge.net/"
@@ -14,14 +14,11 @@ IUSE=""
DEPEND="sys-libs/zlib"
src_compile() {
- local myconf="--with-usbdevfs"
-
- econf ${myconf} || die "econf failed"
+ econf --with-usbdevfs || die "econf failed"
emake || die "compile failure"
}
src_install() {
- einstall
-
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}
diff --git a/app-misc/rioutil/rioutil-1.4.4.ebuild b/app-misc/rioutil/rioutil-1.4.4.ebuild
index 7347e4ec9e83..cf1e46604b2b 100644
--- a/app-misc/rioutil/rioutil-1.4.4.ebuild
+++ b/app-misc/rioutil/rioutil-1.4.4.ebuild
@@ -1,21 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.4.ebuild,v 1.5 2004/06/24 22:30:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.4.ebuild,v 1.6 2004/06/28 04:10:47 vapier Exp $
DESCRIPTION="Command line tool for transfering mp3s to and from a Rio 600, 800, Rio Riot, and Nike PSA/Play"
HOMEPAGE="http://rioutil.sourceforge.net/"
SRC_URI="mirror://sourceforge/rioutil/${P}.tar.bz2"
-RESTRICT="nomirror"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~amd64"
IUSE=""
-RDEPEND="sys-libs/zlib
- virtual/glibc"
-
DEPEND="sys-libs/zlib
- =sys-kernel/linux-headers-2.4*"
+ virtual/libc"
src_compile() {
local myconf="--with-usbdevfs"
@@ -25,7 +22,6 @@ src_compile() {
}
src_install() {
- einstall
-
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}
diff --git a/app-misc/rl/rl-0.2.2.ebuild b/app-misc/rl/rl-0.2.2.ebuild
index 322af2f6a964..f3a620d2af22 100644
--- a/app-misc/rl/rl-0.2.2.ebuild
+++ b/app-misc/rl/rl-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rl/rl-0.2.2.ebuild,v 1.5 2004/06/28 02:00:39 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rl/rl-0.2.2.ebuild,v 1.6 2004/06/28 04:11:03 vapier Exp $
DESCRIPTION="Randomize lines from text files or stdin"
HOMEPAGE="http://tiefighter.et.tudelft.nl/~arthur/rl/"
@@ -8,10 +8,10 @@ SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/rl/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 s390 ~sparc ~mips"
-
+KEYWORDS="~x86 ~sparc ~mips s390"
IUSE="debug"
-DEPEND="virtual/glibc"
+
+DEPEND="virtual/libc"
src_compile() {
local myconf=""
@@ -24,6 +24,5 @@ src_compile() {
src_install() {
make install DESTDIR=${D} || die "install failed"
-
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}
diff --git a/app-misc/rlwrap/rlwrap-0.16.ebuild b/app-misc/rlwrap/rlwrap-0.16.ebuild
index f01e0885b506..a9adb1471fce 100644
--- a/app-misc/rlwrap/rlwrap-0.16.ebuild
+++ b/app-misc/rlwrap/rlwrap-0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rlwrap/rlwrap-0.16.ebuild,v 1.8 2004/06/28 02:04:05 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rlwrap/rlwrap-0.16.ebuild,v 1.9 2004/06/28 04:11:20 vapier Exp $
DESCRIPTION="a 'readline wrapper' which uses the GNU readline lib to allow the editing of keyboard input for any command"
HOMEPAGE="http://utopia.knoware.nl/~hlub/uck/rlwrap/"
@@ -15,5 +15,5 @@ DEPEND="sys-libs/readline"
src_install() {
einstall || die
- dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README
}
diff --git a/app-misc/rolo/rolo-011.ebuild b/app-misc/rolo/rolo-011.ebuild
index ed17e6f1297a..9b711912ddb9 100644
--- a/app-misc/rolo/rolo-011.ebuild
+++ b/app-misc/rolo/rolo-011.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rolo/rolo-011.ebuild,v 1.6 2004/06/24 22:31:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rolo/rolo-011.ebuild,v 1.7 2004/06/28 04:11:36 vapier Exp $
DESCRIPTION="Text-based contact management software using vCards"
HOMEPAGE="http://rolo.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="x86 ~ppc ~sparc alpha"
+IUSE=""
+
DEPEND="dev-libs/libvc
- sys-libs/ncurses"
+ sys-libs/ncurses"
src_install() {
emake DESTDIR=${D} install || die
rm ${D}/usr/share/man/man1/rolo.1 # we will install later via doman
- dodoc AUTHORS COPYING INSTALL NEWS README THANKS TODO ChangeLog doc/rfc2426.txt
+ dodoc AUTHORS INSTALL NEWS README THANKS TODO ChangeLog doc/rfc2426.txt
doman doc/rolo.1
}
-
diff --git a/app-misc/scmxx/scmxx-0.6.3.7.ebuild b/app-misc/scmxx/scmxx-0.6.3.7.ebuild
index 27058690d9a6..0cc78c65b00f 100644
--- a/app-misc/scmxx/scmxx-0.6.3.7.ebuild
+++ b/app-misc/scmxx/scmxx-0.6.3.7.ebuild
@@ -1,21 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/scmxx/scmxx-0.6.3.7.ebuild,v 1.4 2004/06/24 22:32:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/scmxx/scmxx-0.6.3.7.ebuild,v 1.5 2004/06/28 04:12:14 vapier Exp $
-DESCRIPTION="Exchange data with Siemens phones."
+DESCRIPTION="Exchange data with Siemens phones"
HOMEPAGE="http://www.hendrik-sattler.de/scmxx/"
SRC_URI="http://ma2geo.mathematik.uni-karlsruhe.de/~hendrik/scmxx/download/${P}.tar.bz2
http://ma2geo.mathematik.uni-karlsruhe.de/~hendrik/scmxx/download/old/${P}.tar.bz2"
-DEPEND="virtual/glibc"
-IUSE=""
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE=""
-src_compile() {
- econf || die
- emake || die
-}
+DEPEND="virtual/libc"
src_install() {
make DESTDIR=${D} install || die
diff --git a/app-misc/scmxx/scmxx-0.6.4.ebuild b/app-misc/scmxx/scmxx-0.6.4.ebuild
index c147b5017d8b..4befb6da5608 100644
--- a/app-misc/scmxx/scmxx-0.6.4.ebuild
+++ b/app-misc/scmxx/scmxx-0.6.4.ebuild
@@ -1,20 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/scmxx/scmxx-0.6.4.ebuild,v 1.4 2004/06/24 22:32:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/scmxx/scmxx-0.6.4.ebuild,v 1.5 2004/06/28 04:12:14 vapier Exp $
-DESCRIPTION="Exchange data with Siemens phones."
+DESCRIPTION="Exchange data with Siemens phones"
HOMEPAGE="http://www.hendrik-sattler.de/scmxx/"
SRC_URI="mirror://sourceforge/scmxx/${P}.tar.bz2"
-DEPEND="virtual/glibc"
-IUSE=""
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE=""
-src_compile() {
- econf || die
- emake || die
-}
+DEPEND="virtual/libc"
src_install() {
make DESTDIR=${D} install || die
diff --git a/app-misc/screen/screen-4.0.2.ebuild b/app-misc/screen/screen-4.0.2.ebuild
index 15b6dadbbe87..f757bbfd726c 100644
--- a/app-misc/screen/screen-4.0.2.ebuild
+++ b/app-misc/screen/screen-4.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.2.ebuild,v 1.8 2004/06/24 22:32:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.2.ebuild,v 1.9 2004/06/28 04:12:34 vapier Exp $
inherit eutils flag-o-matic
@@ -83,7 +83,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
dobin screen || die "dobin failed"
keepdir /var/run/screen
fowners root:utmp /{usr/bin,var/run}/screen
diff --git a/app-misc/secure-delete/secure-delete-3.0.ebuild b/app-misc/secure-delete/secure-delete-3.0.ebuild
index 215838481880..de278018d9ba 100644
--- a/app-misc/secure-delete/secure-delete-3.0.ebuild
+++ b/app-misc/secure-delete/secure-delete-3.0.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/secure-delete/secure-delete-3.0.ebuild,v 1.9 2004/06/24 22:32:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/secure-delete/secure-delete-3.0.ebuild,v 1.10 2004/06/28 04:12:52 vapier Exp $
MY_P=${PN//-/_}-${PV}
S=${WORKDIR}/${MY_P}
DESCRIPTION="Secure file/disk/swap/memory erasure utlities"
HOMEPAGE="http://www.thc.org/"
SRC_URI="http://www.thc.org/releases/${MY_P}.tar.gz"
-IUSE=""
-SLOT="0"
+
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc alpha ~hppa ~mips ~amd64 ~ia64 ~ppc64"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips alpha ~hppa ~amd64 ~ia64 ~ppc64"
+IUSE=""
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
!app-misc/srm"
diff --git a/app-misc/sl/sl-3.03.ebuild b/app-misc/sl/sl-3.03.ebuild
index 8112af16f15f..632bcfb10988 100644
--- a/app-misc/sl/sl-3.03.ebuild
+++ b/app-misc/sl/sl-3.03.ebuild
@@ -1,16 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sl/sl-3.03.ebuild,v 1.4 2004/06/24 22:33:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sl/sl-3.03.ebuild,v 1.5 2004/06/28 04:13:13 vapier Exp $
inherit eutils
-IUSE="cjk"
-
SL_PATCH="sl5-1.patch"
-DESCRIPTION="SL is a sophisticated graphical program which corrects your miss typing"
-HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/
- http://www.linet.gr.jp/~izumi/sl/"
+DESCRIPTION="sophisticated graphical program which corrects your miss typing"
+HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/ http://www.linet.gr.jp/~izumi/sl/"
SRC_URI="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/sl/${PN}.tar
http://www.linet.gr.jp/~izumi/sl/${SL_PATCH}
http://www.sodan.ecc.u-tokyo.ac.jp/~okayama/sl/${PN}.en.1.gz"
@@ -18,17 +15,17 @@ SRC_URI="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/sl/${PN}.tar
LICENSE="freedist"
SLOT="0"
KEYWORDS="x86 alpha ~sparc"
+IUSE="cjk"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/ncurses
cjk? ( app-i18n/nkf )"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
sys-libs/ncurses"
S=${WORKDIR}/${PN}
src_unpack() {
-
unpack ${PN}.tar
cd ${S}
epatch ${DISTDIR}/${SL_PATCH}
@@ -37,7 +34,6 @@ src_unpack() {
}
src_compile() {
-
emake CFLAGS="${CFLAGS}" LDFLAGS="-lncurses" || die
if use cjk; then
nkf -e sl.1 > sl.ja.1
@@ -45,8 +41,7 @@ src_compile() {
}
src_install() {
-
- dobin sl
+ dobin sl || die
newman sl.en.1 sl.1
dodoc README* sl.txt
if use cjk ; then
diff --git a/app-misc/slmon/slmon-0.5.12.ebuild b/app-misc/slmon/slmon-0.5.12.ebuild
index feaf7315861e..e3f5760514f6 100644
--- a/app-misc/slmon/slmon-0.5.12.ebuild
+++ b/app-misc/slmon/slmon-0.5.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/slmon/slmon-0.5.12.ebuild,v 1.5 2004/06/24 22:33:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/slmon/slmon-0.5.12.ebuild,v 1.6 2004/06/28 04:13:29 vapier Exp $
DESCRIPTION="Colored text-based system performance monitor"
HOMEPAGE="http://slmon.sourceforge.net/"
@@ -14,12 +14,7 @@ IUSE=""
DEPEND="gnome-base/libgtop
sys-libs/slang"
-src_compile() {
- econf || die "configure problem"
- emake || die "compile problem"
-}
-
src_install() {
einstall || die "install problem"
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
}
diff --git a/app-misc/smtm/smtm-1.4.0.ebuild b/app-misc/smtm/smtm-1.4.0.ebuild
index a8fc710e75f2..101f99343a2f 100644
--- a/app-misc/smtm/smtm-1.4.0.ebuild
+++ b/app-misc/smtm/smtm-1.4.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/smtm/smtm-1.4.0.ebuild,v 1.10 2004/06/24 22:33:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/smtm/smtm-1.4.0.ebuild,v 1.11 2004/06/28 04:13:52 vapier Exp $
DESCRIPTION="Stock ticker, profit/loss calculator and chart tool"
HOMEPAGE="http://eddelbuettel.com/dirk/code/smtm.html"
SRC_URI="http://eddelbuettel.com/dirk/code/smtm/smtm_${PV}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc"
IUSE=""
@@ -19,11 +19,10 @@ DEPEND=">=dev-lang/perl-5
S=${WORKDIR}
src_install() {
- exeinto /usr/bin
- doexe smtm
+ dobin smtm || die
dohtml smtm.html
- dodoc BUGS COPYING THANKS TODO
+ dodoc BUGS THANKS TODO
docinto examples
dodoc examples/*.smtm
}