summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/gentoo-syntax/ChangeLog11
-rw-r--r--app-vim/gentoo-syntax/Manifest8
-rw-r--r--app-vim/gentoo-syntax/files/digest-gentoo-syntax-200412271
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20041227.ebuild52
4 files changed, 68 insertions, 4 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index a1b3558540d6..d7c15f078603 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.25 2004/12/16 05:17:20 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.26 2004/12/27 17:41:33 ciaranm Exp $
+
+*gentoo-syntax-20041227 (27 Dec 2004)
+
+ 27 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org>
+ +gentoo-syntax-20041227.ebuild:
+ New version. Changes include an update to make arch detection work again
+ with the new make.defaults setup, extra error checking on make.conf SLOT and
+ CFLAGS, many new ebuild creation templates and new metadata and guidexml
+ syntax rules.
16 Dec 2004; Dylan Carlson <absinthe@gentoo.org>
gentoo-syntax-20041202.ebuild:
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 864032343d33..62d5da034343 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,8 +1,10 @@
MD5 10c97b2ca29c1273925b0c1317885e6a ChangeLog 4676
-MD5 a8fcba96f97e87e500b968639f33ed99 gentoo-syntax-20041009.ebuild 649
MD5 319cdd203f22ade00e4939e20955f378 gentoo-syntax-20041113.ebuild 1834
-MD5 9cb274b3549ab50686519b3490912757 gentoo-syntax-20041202.ebuild 1835
+MD5 a8fcba96f97e87e500b968639f33ed99 gentoo-syntax-20041009.ebuild 649
+MD5 8b80f2dddc2e195857a69e7bee32e904 gentoo-syntax-20041227.ebuild 1840
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
-MD5 af854ba426622a145f3f786c605ff98c files/digest-gentoo-syntax-20041009 73
+MD5 9cb274b3549ab50686519b3490912757 gentoo-syntax-20041202.ebuild 1835
+MD5 c8e3ac5d8a31716f27516db1f6d138c9 files/digest-gentoo-syntax-20041227 74
MD5 8ae17c577573d3654205f007a4ecb6ce files/digest-gentoo-syntax-20041113 73
MD5 b5f329b0b88bc9f4ab39100919448b1f files/digest-gentoo-syntax-20041202 74
+MD5 af854ba426622a145f3f786c605ff98c files/digest-gentoo-syntax-20041009 73
diff --git a/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041227 b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041227
new file mode 100644
index 000000000000..362a9d2a7521
--- /dev/null
+++ b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041227
@@ -0,0 +1 @@
+MD5 4cbe8a3abd98ae4242ec32ec3b66e009 gentoo-syntax-20041227.tar.bz2 14329
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20041227.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20041227.ebuild
new file mode 100644
index 000000000000..033ecb8c5f6d
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20041227.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20041227.ebuild,v 1.1 2004/12/27 17:41:33 ciaranm Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage
+Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://developer.berlios.de/projects/gentoo-syntax"
+LICENSE="vim"
+KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc ~ppc64 ~alpha ~ia64"
+SRC_URI="http://download.berlios.de/gentoo-syntax/${P}.tar.bz2"
+
+# For gathering stats. Evil, I know, but I need to know whether I can
+# reasonably add this package in as a PDEPEND of vim-core. -- ciaranm
+RESTRICT="nomirror"
+
+IUSE="ignore-glep31"
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ einfo "Note for developers and anyone else who edits ebuilds:"
+ einfo " This release of gentoo-syntax now contains filetype rules to set"
+ einfo " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ einfo " If you find this feature breaks things, please submit a bug and"
+ einfo " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ einfo " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}
+