summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/turck-mmcache/ChangeLog8
-rw-r--r--dev-php/turck-mmcache/Manifest4
-rw-r--r--dev-php/turck-mmcache/files/digest-turck-mmcache-2.3.191
-rw-r--r--dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild65
4 files changed, 76 insertions, 2 deletions
diff --git a/dev-php/turck-mmcache/ChangeLog b/dev-php/turck-mmcache/ChangeLog
new file mode 100644
index 000000000000..d2fb8e7fdd8e
--- /dev/null
+++ b/dev-php/turck-mmcache/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/ipv6tools
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/turck-mmcache/ChangeLog,v 1.1 2003/07/19 07:33:17 stuart Exp $
+
+*turck-mmcache-2.3.19 (11 07 2003)
+
+ 11 07 2003; Stuart Herbert <stuart@gentoo.org> turck-mmcache-2.3.19.ebuild:
+ Initial add; contributed by Klavs Klavsen <kl@vsen.dk> (see bug #23360)
diff --git a/dev-php/turck-mmcache/Manifest b/dev-php/turck-mmcache/Manifest
index 173652db429d..a69ab04c7200 100644
--- a/dev-php/turck-mmcache/Manifest
+++ b/dev-php/turck-mmcache/Manifest
@@ -1,3 +1,3 @@
-MD5 ae762c5380328ba5a116769bad7ad2cc turck-mmcache-2.3.19.ebuild 2154
-MD5 afcfc7c86d89187b55a972008decda19 ChangeLog 315
+MD5 b7abe1bf89e0a7c690582d9a691c060d turck-mmcache-2.3.19.ebuild 2266
+MD5 492df5da6b9927a2b97a7e9f55f02f85 ChangeLog 409
MD5 73606cb81a8ce6f7b1b300724ecf7307 files/digest-turck-mmcache-2.3.19 71
diff --git a/dev-php/turck-mmcache/files/digest-turck-mmcache-2.3.19 b/dev-php/turck-mmcache/files/digest-turck-mmcache-2.3.19
new file mode 100644
index 000000000000..e80b9376afe3
--- /dev/null
+++ b/dev-php/turck-mmcache/files/digest-turck-mmcache-2.3.19
@@ -0,0 +1 @@
+MD5 6adfff394a13aa181eb127caeed7224b turck-mmcache-2.3.19.tar.gz 94209
diff --git a/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild b/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild
new file mode 100644
index 000000000000..da61a85c972e
--- /dev/null
+++ b/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild,v 1.1 2003/07/19 07:33:17 stuart Exp $
+
+DESCRIPTION="Turck MMCache is a free open source PHP accelerator, optimizer, encoder and dynamic content cache for PHP. It increases performance of PHP scripts by caching them in compiled state, so that the overhead of compiling is almost completely eliminated. Also it uses some optimizations to speed up execution of PHP scripts. Turck MMCache typically reduces server load and increases the speed of your PHP code by 1-10 times."
+SRC_URI="mirror://sourceforge/turck-mmcache/${P}.tar.gz"
+HOMEPAGE="http://turck-mmcache.sourceforge.net/"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+PHP_EXT_NAME="mmcache"
+PHP_EXT_ZENDEXT="yes"
+
+inherit php-ext
+
+src_compile() {
+ myconf="--enable-mmcache=shared"
+ php-ext_src_compile
+}
+
+src_install() {
+
+ php-ext_src_install
+
+ #create Cache dir if it does not exist
+ if [ ! -d /tmp/mmcache ]
+ then
+ mkdir /tmp/mmcache
+ fi
+ # doesn't hurt :)
+ chmod 0777 /tmp/mmcache
+
+ insinto /usr/share/${PN}
+ doins encoder.php mmcache.php mmcache.gif
+
+ dodoc CREDITS LICENSE README TODO EXPERIMENTAL
+}
+
+pkg_postinst () {
+ php-ext_pkg_postinst
+
+ php-ext_addtoinifiles "mmcache.shm_size" '"16"'
+ php-ext_addtoinifiles "mmcache.cache_dir" '"/tmp/mmcache"'
+ php-ext_addtoinifiles "mmcache.enable" '"1"'
+ php-ext_addtoinifiles "mmcache.optimizer" '"1"'
+ php-ext_addtoinifiles "mmcache.check_mtime" '"1"'
+ php-ext_addtoinifiles "mmcache.debug" '"0"'
+ php-ext_addtoinifiles "mmcache.filter" '""'
+ php-ext_addtoinifiles "mmcache.shm_max" '"0"'
+ php-ext_addtoinifiles "mmcache.shm_ttl" '"0"'
+ php-ext_addtoinifiles "mmcache.shm_prune_period" '"0"'
+
+ einfo "You need to restart apache to activate MMCache"
+ einfo
+ einfo 'A web interface is available to manage the turck cache.'
+ einfo 'Copy /usr/share/turck-mmcache/mmcache.php to somewhere'
+ einfo 'where your web server can see it.'
+ einfo
+ einfo 'A PHP script encoder is available to encode your PHP scripts.'
+ einfo 'The encoder is available as /usr/share/turck-mmcache/encoder.php'
+ einfo 'The encoded file format is not yet considered stable'
+}