summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/python/python-2.2.1-r5.ebuild7
-rw-r--r--sys-devel/perl/perl-5.6.1-r7.ebuild9
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-lang/python/python-2.2.1-r5.ebuild b/dev-lang/python/python-2.2.1-r5.ebuild
index b9846ab1ff8d..55a07eb30350 100644
--- a/dev-lang/python/python-2.2.1-r5.ebuild
+++ b/dev-lang/python/python-2.2.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r5.ebuild,v 1.4 2002/10/15 19:50:14 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r5.ebuild,v 1.5 2002/10/17 16:34:48 bjb Exp $
IUSE="readline tcltk berkdb bootstrap"
@@ -41,6 +41,11 @@ src_unpack() {
src_compile() {
filter-flags -malign-double
+
+ if [ "${ARCH}" = "alpha" ]; then
+ CFLAGS="${CFLAGS} -fPIC"
+ CXXFLAGS="${CXXFLAGS} -fPIC"
+ fi
export OPT="$CFLAGS"
# adjust makefile to install pydoc into ${D} correctly
diff --git a/sys-devel/perl/perl-5.6.1-r7.ebuild b/sys-devel/perl/perl-5.6.1-r7.ebuild
index e090eb133285..0f00fff8917c 100644
--- a/sys-devel/perl/perl-5.6.1-r7.ebuild
+++ b/sys-devel/perl/perl-5.6.1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r7.ebuild,v 1.4 2002/10/13 11:57:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r7.ebuild,v 1.5 2002/10/17 16:34:48 bjb Exp $
IUSE="berkdb gdbm"
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${P}.tar.gz"
HOMEPAGE="http://www.perl.org"
LICENSE="Artistic GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc sparc64"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
RDEPEND="gdbm? ( >=sys-libs/gdbm-1.8.0 )
berkdb? ( >=sys-libs/db-3.2.3h-r3
@@ -21,6 +21,11 @@ DEPEND="sys-apps/groff
src_compile() {
+ if [ "${ARCH}" = "alpha" ]; then
+ CFLAGS="${CFLAGS} -fPIC"
+ CXXFLAGS="${CXXFLAGS} -fPIC"
+ fi
+
local myconf
if [ "`use gdbm`" ]
then