summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/kde-dist.eclass4
-rw-r--r--kde-base/arts/arts-1.1.0.2.ebuild4
-rw-r--r--kde-base/kdelibs/kdelibs-3.1_rc2.ebuild4
3 files changed, 7 insertions, 5 deletions
diff --git a/eclass/kde-dist.eclass b/eclass/kde-dist.eclass
index 9a669e3891f1..5a0824b48fa6 100644
--- a/eclass/kde-dist.eclass
+++ b/eclass/kde-dist.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-dist.eclass,v 1.28 2002/11/05 00:07:46 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-dist.eclass,v 1.29 2002/11/09 21:40:11 danarmak Exp $
# This is the kde-dist eclass for >=2.2.1 kde base packages. Don't use for kdelibs though :-)
# Don't use it for e.g. kdevelop, koffice because of their separate versionnig schemes.
@@ -22,7 +22,7 @@ DESCRIPTION="KDE ${PV} - "
HOMEPAGE="http://www.kde.org/"
# doesn't work well for unstable versions
-if [ "$PV" != "3.1_alpha1" -a "$PV" != "3.1_beta1" -a "$PV" != "3.1_beta2" -a "$PV" != "3.1_rc1" -a "$PV" != "3.1_rc2" -a "$PV" != "5" ]; then
+if [ "$PV" != "3.1_alpha1" -a "$PV" != "3.1_beta1" -a "$PV" != "3.1_beta2" -a "$PV" != "3.1_rc1" -a "$PV" != "5" ]; then
set_enable_final
fi
diff --git a/kde-base/arts/arts-1.1.0.2.ebuild b/kde-base/arts/arts-1.1.0.2.ebuild
index ea14a9076d18..12480baa20e7 100644
--- a/kde-base/arts/arts-1.1.0.2.ebuild
+++ b/kde-base/arts/arts-1.1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.0.2.ebuild,v 1.2 2002/11/05 03:13:35 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.0.2.ebuild,v 1.3 2002/11/09 21:40:36 danarmak Exp $
inherit kde-base flag-o-matic
# this is the arts 1.1.0 rfom kde 3.1 rc2, as opposed to the arta 1.1.0 rfom kde 3.1 beta2
@@ -24,6 +24,8 @@ LICENSE="GPL-2 LGPL-2"
use alsa && myconf="$myconf --enable-alsa" || myconf="$myconf --disable-alsa"
+set_enable_final
+
src_unpack() {
base_src_unpack
diff --git a/kde-base/kdelibs/kdelibs-3.1_rc2.ebuild b/kde-base/kdelibs/kdelibs-3.1_rc2.ebuild
index ed447fdb1c39..79160b722dd5 100644
--- a/kde-base/kdelibs/kdelibs-3.1_rc2.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.1_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1_rc2.ebuild,v 1.1 2002/11/05 00:03:57 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1_rc2.ebuild,v 1.2 2002/11/09 21:40:57 danarmak Exp $
inherit kde kde.org
#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
@@ -41,7 +41,7 @@ RDEPEND="$RDEPEND
>=sys-apps/portage-2.0.36" # for #7359
myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
-#set_enable_final
+set_enable_final
qtver-from-kdever ${PV}
need-qt $selected_version