summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/pam_dotfile/ChangeLog5
-rw-r--r--app-admin/pam_dotfile/pam_dotfile-0.7.ebuild22
2 files changed, 22 insertions, 5 deletions
diff --git a/app-admin/pam_dotfile/ChangeLog b/app-admin/pam_dotfile/ChangeLog
index d9dca95f5b52..ffb5a289db1f 100644
--- a/app-admin/pam_dotfile/ChangeLog
+++ b/app-admin/pam_dotfile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/pam_dotfile
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/ChangeLog,v 1.3 2004/06/24 21:33:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/ChangeLog,v 1.4 2004/07/13 17:11:44 aliz Exp $
+
+ 13 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> pam_dotfile-0.7.ebuild:
+ Fixed lynx problems, closing #56424.
06 Jun 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
pam_dotfile-0.7.ebuild:
diff --git a/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild b/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild
index e60bf22f93d4..00a266938367 100644
--- a/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild
+++ b/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild,v 1.6 2004/06/24 21:33:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pam_dotfile/pam_dotfile-0.7.ebuild,v 1.7 2004/07/13 17:11:44 aliz Exp $
MY_P="${P/_beta/beta}"
S="${WORKDIR}/${MY_P}"
@@ -11,9 +11,23 @@ SRC_URI="http://www.stud.uni-hamburg.de/users/lennart/projects/pam_dotfile/${MY_
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-DEPEND=">=sys-libs/pam-0.72"
+KEYWORDS="x86 ~amd64"
+IUSE="doc"
+DEPEND="doc? ( net-www/lynx )
+ >=sys-libs/pam-0.72"
+
+src_compile() {
+ local myconf
+
+ if use doc; then
+ myconf="--enable-lynx"
+ else
+ myconf="--disable-lynx"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
src_install() {
make -C src DESTDIR=${D} install