summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/bluefish/bluefish-0.7-r3.ebuild27
-rw-r--r--app-editors/bluefish/bluefish-2002.11.08.ebuild25
-rw-r--r--app-editors/e3/e3-1.7-r1.ebuild17
3 files changed, 25 insertions, 44 deletions
diff --git a/app-editors/bluefish/bluefish-0.7-r3.ebuild b/app-editors/bluefish/bluefish-0.7-r3.ebuild
index 4cd16069516c..0b3b96427b02 100644
--- a/app-editors/bluefish/bluefish-0.7-r3.ebuild
+++ b/app-editors/bluefish/bluefish-0.7-r3.ebuild
@@ -1,43 +1,36 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.7-r3.ebuild,v 1.1 2002/11/14 17:06:11 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.7-r3.ebuild,v 1.2 2002/11/30 21:55:02 vapier Exp $
-IUSE="gnome nls perl"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
HOMEPAGE="http://bluefish.openoffice.nl/"
+
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
SLOT="0"
+IUSE="gnome nls perl"
DEPEND="=x11-libs/gtk+-1.2*
>=media-libs/imlib-1.9.10-r1
- perl? ( sys-devel/perl )
- nls? ( sys-devel/gettext )"
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
src_compile() {
- local myconf=""
-
+ local myconf="--with-autocomplet"
use perl && myconf="${myconf} --with-perl"
use nls || myconf="${myconf} --disable-nls"
-
- econf \
- --with-autocomplet \
- ${myconf} || die "./configure failed"
+ econf ${myconf}
emake || die "Compilation failed"
-
}
-src_install () {
+src_install() {
einstall \
pkgdatadir=${D}/usr/share/bluefish \
- pixmapsdir=${D}/usr/share/pixmaps || die "Installation failed"
+ pixmapsdir=${D}/usr/share/pixmaps
- if [ "`use gnome`" ]
- then
+ if [ "`use gnome`" ] ; then
insinto /usr/share/gnome/apps/Development/
doins data/bluefish.desktop
fi
diff --git a/app-editors/bluefish/bluefish-2002.11.08.ebuild b/app-editors/bluefish/bluefish-2002.11.08.ebuild
index ad35632a2211..fab1c2ed22de 100644
--- a/app-editors/bluefish/bluefish-2002.11.08.ebuild
+++ b/app-editors/bluefish/bluefish-2002.11.08.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-2002.11.08.ebuild,v 1.1 2002/11/16 10:16:18 hanno Exp $
-
-IUSE="nls perl"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-2002.11.08.ebuild,v 1.2 2002/11/30 21:56:57 vapier Exp $
MY_PV=`echo ${PV} | sed -e 's/\./-/g'`
S=${WORKDIR}/${PN}-gtk2
DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/snapshots/${PN}-gtk2port-${MY_PV}.tgz"
HOMEPAGE="http://bluefish.openoffice.nl/"
+
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
SLOT="0"
+IUSE="nls perl"
DEPEND=">=x11-libs/gtk+-2.0.5
>=media-libs/freetype-2.0.9
@@ -19,29 +19,19 @@ DEPEND=">=x11-libs/gtk+-2.0.5
perl? ( sys-devel/perl )
nls? ( sys-devel/gettext )"
-
src_compile() {
-
- local myconf
+ local myconf="--with-autocomplet"
use perl && myconf="${myconf} --with-perl"
use nls || myconf="${myconf} --disable-nls"
-
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --host=${CHOST} \
- --with-autocomplet \
- ${myconf} || die
+ econf ${myconf}
emake || die
-
}
-src_install () {
-
+src_install() {
makefiles=`find . -name Makefile`
for f in $makefiles; do
- mv $f $f.orig
+ mv $f $f.orig
sed -e 's#$(prefix)#$(DESTDIR)$(prefix)#' \
-e 's#${prefix}#$(DESTDIR)${prefix}#' \
-e 's#/usr/share/pixmaps#$(DESTDIR)$(prefix)/share/pixmaps#' \
@@ -52,5 +42,4 @@ src_install () {
DESTDIR=${D} \
mandir=${D}/usr/share/man \
install || die
-
}
diff --git a/app-editors/e3/e3-1.7-r1.ebuild b/app-editors/e3/e3-1.7-r1.ebuild
index 27118f138a44..5457ade36234 100644
--- a/app-editors/e3/e3-1.7-r1.ebuild
+++ b/app-editors/e3/e3-1.7-r1.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-#
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r1.ebuild,v 1.7 2002/10/04 04:04:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r1.ebuild,v 1.8 2002/11/30 21:58:51 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
-HOMEPAGE="http://www.sax.de/~adlibit"
-DEPEND="dev-lang/nasm
- >=sys-apps/gzip-1.2.4a-r6"
-RDEPEND="sys-apps/sed"
+HOMEPAGE="http://www.sax.de/~adlibit/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND="dev-lang/nasm
+ >=sys-apps/gzip-1.2.4a-r6"
+RDEPEND="sys-apps/sed"
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}
patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
}
+
src_compile() {
emake || die
}
-src_install () {
+src_install() {
dodir /usr/bin
dobin e3
dosym e3 /usr/bin/e3vi
@@ -36,4 +36,3 @@ src_install () {
cp e3.man e3.1
doman e3.1
}
-