summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/snd/ChangeLog7
-rw-r--r--media-sound/snd/Manifest4
-rw-r--r--media-sound/snd/files/digest-snd-7.11
-rw-r--r--media-sound/snd/snd-7.1.ebuild76
4 files changed, 85 insertions, 3 deletions
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index a2e9f06a4d19..0aa2266ed78e 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/snd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.8 2004/01/08 00:13:41 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.9 2004/01/10 23:55:51 mholzer Exp $
+
+*snd-7.1 (11 Jan 2004)
+
+ 11 Jan 2004; Martin Holzer <mholzer@gentoo.org> snd-7.1.ebuild:
+ Version bumped
*snd-7.0 (08 Jan 2004)
diff --git a/media-sound/snd/Manifest b/media-sound/snd/Manifest
index 31b2505c716a..132a3302ea04 100644
--- a/media-sound/snd/Manifest
+++ b/media-sound/snd/Manifest
@@ -1,7 +1,7 @@
-MD5 d6a2e210976115b7d67ca6b2c1dcaa9d ChangeLog 1195
+MD5 a02e5cdbfbac965426f2954ac90efe34 ChangeLog 1303
MD5 05efb7ff12c5da58ebcc922686819df5 snd-6.7.ebuild 1688
MD5 527dcfe3ce0f0b53c6b6aa8b82eb930c metadata.xml 252
-MD5 811e50656cfcba3c62b1792c3c2558f2 snd-7.1.ebuild 1688
+MD5 68e19cbad23c0475b2f5e5ca365f4977 snd-7.1.ebuild 1746
MD5 811e50656cfcba3c62b1792c3c2558f2 snd-7.0.ebuild 1688
MD5 2c4ab24ebd10504d1d4f2a704ea4e309 files/digest-snd-7.1 60
MD5 cfd80dce79511197bafc596a9125c832 files/digest-snd-6.7 60
diff --git a/media-sound/snd/files/digest-snd-7.1 b/media-sound/snd/files/digest-snd-7.1
new file mode 100644
index 000000000000..ae4ebd35c98a
--- /dev/null
+++ b/media-sound/snd/files/digest-snd-7.1
@@ -0,0 +1 @@
+MD5 19ca418418c7421dd3bffdf196f3780a snd-7.1.tar.gz 5099045
diff --git a/media-sound/snd/snd-7.1.ebuild b/media-sound/snd/snd-7.1.ebuild
new file mode 100644
index 000000000000..73dceeddedb2
--- /dev/null
+++ b/media-sound/snd/snd-7.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-7.1.ebuild,v 1.1 2004/01/10 23:55:52 mholzer Exp $
+
+IUSE="esd motif guile X gtk ruby alsa"
+
+S="${WORKDIR}/${P/\.*//}"
+DESCRIPTION="Snd is a sound editor"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://snd.sourceforge.net"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ dev-libs/gsl
+ media-libs/ladspa-sdk
+ media-libs/audiofile
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )
+ gtk? ( x11-libs/gtk+ )
+ guile? ( dev-util/guile )
+ motif? ( x11-libs/openmotif )
+ ruby? ( dev-lang/ruby )"
+
+
+src_compile() {
+ local myconf
+
+ use alsa \
+ && myconf="${myconf} --with-alsa" \
+ || myconf="${myconf} --without-alsa"
+
+ use esd \
+ && myconf="${myconf} --with-esd" \
+ || myconf="${myconf} --without-esd"
+
+ use gtk \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use guile \
+ && myconf="${myconf} --with-guile --with-run" \
+ || myconf="${myconf} --without-guile"
+
+ use ruby \
+ && myconf="${myconf} --with-ruby" \
+ || myconf="${myconf} --without-ruby"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+# Seems to cause problem I will look into it but for now we will just disable
+# use gl \
+# && myconf="${myconf} --with-just-gl" \
+# || myconf="${myconf} --without-gl"
+
+ econf --with-ladspa --with-float-samples \
+ --with-float-sample-width ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ dobin snd
+
+ dodoc COPYING HISTORY.Snd README.Snd TODO.Snd
+
+ cd tutorial
+ dohtml *
+ insinto /usr/share/doc/${PF}/html/images/jpg
+ doins images/jpg/*
+}