summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/gentoo-web/gentoo-web-2.2.ebuild4
-rw-r--r--sys-apps/baselayout/baselayout-1.7.6.ebuild11
-rw-r--r--sys-apps/portage/portage-1.8.9.ebuild4
3 files changed, 11 insertions, 8 deletions
diff --git a/app-doc/gentoo-web/gentoo-web-2.2.ebuild b/app-doc/gentoo-web/gentoo-web-2.2.ebuild
index 1bb64d3c4320..05cccf38664e 100644
--- a/app-doc/gentoo-web/gentoo-web-2.2.ebuild
+++ b/app-doc/gentoo-web/gentoo-web-2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc. Distributed under the terms
# of the GNU General Public License, v2 or later
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-doc/gentoo-web/gentoo-web-2.2.ebuild,v 1.41 2002/03/07 16:46:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/gentoo-web/gentoo-web-2.2.ebuild,v 1.42 2002/03/31 19:17:51 drobbins Exp $
# WARNING: THIS EBUILD SHOULD BE EDITED BY DANIEL ROBBINS ONLY
@@ -113,6 +113,8 @@ src_install() {
dobin ${DISTDIR}/cvs2cl.pl
dosbin ${S}/bin/cvslog.sh
+ cd ${D}
+ chmod -R +r *
}
pkg_preinst() {
diff --git a/sys-apps/baselayout/baselayout-1.7.6.ebuild b/sys-apps/baselayout/baselayout-1.7.6.ebuild
index 942803d6d67a..a4e6069e9859 100644
--- a/sys-apps/baselayout/baselayout-1.7.6.ebuild
+++ b/sys-apps/baselayout/baselayout-1.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.7.6.ebuild,v 1.1 2002/03/24 19:12:57 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.7.6.ebuild,v 1.2 2002/03/31 19:17:51 drobbins Exp $
SV="1.3.2"
SVREV=""
@@ -15,10 +15,11 @@ HOMEPAGE="http://www.gentoo.org"
DEPEND="sys-kernel/linux-headers"
RDEPEND=""
-if [ -z "`use build`" ]
-then
- RDEPEND="sys-apps/kbd"
-fi
+#baselayout shouldn't have any runtime dependencies. it creates circular deps fast.
+#if [ -z "`use build`" ]
+#then
+# RDEPEND="sys-apps/kbd"
+#fi
#This ebuild needs to be merged "live". You can't simply make a package of it and merge it later.
diff --git a/sys-apps/portage/portage-1.8.9.ebuild b/sys-apps/portage/portage-1.8.9.ebuild
index c9f82b7f53b9..b35df20146ed 100644
--- a/sys-apps/portage/portage-1.8.9.ebuild
+++ b/sys-apps/portage/portage-1.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc. Distributed under the terms
# of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.8.9.ebuild,v 1.3 2002/03/31 18:50:24 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.8.9.ebuild,v 1.4 2002/03/31 19:17:51 drobbins Exp $
S=${WORKDIR}/${P}
SLOT="0"
@@ -13,7 +13,7 @@ if [ "`use build`" ]
then
RDEPEND=""
else
- RDEPEND=">=sys-apps/fileutils-4.1.8 >=dev-lang/python-2.2 sys-apps/debianutils"
+ RDEPEND=">=sys-apps/fileutils-4.1.8 =dev-lang/python-2.2* sys-apps/debianutils"
fi
src_unpack() {