summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/aspell/ChangeLog9
-rw-r--r--app-text/aspell/aspell-0.50_pre20020815.ebuild64
-rw-r--r--app-text/aspell/files/digest-aspell-0.50_pre200208151
3 files changed, 73 insertions, 1 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index e49ce54c2562..3869a007a7aa 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/aspell
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.8 2002/08/14 02:56:35 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.9 2002/08/16 07:10:19 seemant Exp $
+
+*aspell-0.50_pre20020815 (16 Aug 2002)
+
+ 16 Aug 2002; Seemant Kulleen <seemant@gentoo.org>
+ aspell-0.50_pre20020815.ebuild :
+
+ version bump.
*aspell-0.50_pre20020811 (13 Aug 2002)
diff --git a/app-text/aspell/aspell-0.50_pre20020815.ebuild b/app-text/aspell/aspell-0.50_pre20020815.ebuild
new file mode 100644
index 000000000000..31872e5c1344
--- /dev/null
+++ b/app-text/aspell/aspell-0.50_pre20020815.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50_pre20020815.ebuild,v 1.1 2002/08/16 07:10:19 seemant Exp $
+
+inherit libtool
+
+MY_P=${P/_pre/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A spell checker replacement for ispell"
+SRC_URI="http://savannah.gnu.org/download/aspell/${MY_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/aspell/index.html"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+#
+# These flags a reset here because too much optimisation can cause aspell's
+# compilation process to break. Moreover, these must be set before ./configure
+# otherwise it breaks again. A very fragile build process, really.
+#
+CXXFLAGS="-O2"
+CFLAGS=${CXXFLAGS}
+
+# needed to compile
+
+if [ -e /lib/libc-2.2.5.so ] && [ `gcc -dumpversion` == "2.95.3" ]; then
+ if [ ! -f /etc/aspell/aspell.conf ]; then
+ mkdir -p /etc/aspell
+ touch /etc/aspell/aspell.conf
+ fi
+ if [ ! -f /root/.aspell.conf ]; then
+ touch /root/.aspell.conf
+ fi
+fi
+
+src_compile() {
+ elibtoolize
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ cd ${D}/usr/share/doc/${P}
+ dohtml -r man-html
+ docinto text
+ dodoc man-text
+ cd ${S}
+
+# dosym /usr/lib/libpspell.so.15 /usr/lib/libpspell.so
+
+ dodoc README* TODO
+
+}
diff --git a/app-text/aspell/files/digest-aspell-0.50_pre20020815 b/app-text/aspell/files/digest-aspell-0.50_pre20020815
new file mode 100644
index 000000000000..b86eaa09aa11
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.50_pre20020815
@@ -0,0 +1 @@
+MD5 8754ddf72199aedc51df0c201208666c aspell-0.50-20020815.tar.gz 910953