summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/oro/oro-2.0.6-r2.ebuild26
-rw-r--r--dev-java/oro/oro-2.0.7.ebuild26
-rw-r--r--dev-java/xom/xom-1.0.14.ebuild16
-rw-r--r--dev-lang/ghc-bin/ghc-bin-5.04.2-r1.ebuild4
-rw-r--r--dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild4
-rw-r--r--dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild4
-rw-r--r--dev-lang/ghc-bin/ghc-bin-6.0.ebuild4
-rw-r--r--dev-lang/helium/helium-1.1.ebuild17
-rw-r--r--dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild14
-rw-r--r--dev-lang/stratego/stratego-0.8.1.ebuild19
-rw-r--r--dev-lang/stratego/stratego-0.8.ebuild18
11 files changed, 75 insertions, 77 deletions
diff --git a/dev-java/oro/oro-2.0.6-r2.ebuild b/dev-java/oro/oro-2.0.6-r2.ebuild
index fee9a8bb2d59..ef063961c41e 100644
--- a/dev-java/oro/oro-2.0.6-r2.ebuild
+++ b/dev-java/oro/oro-2.0.6-r2.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.6-r2.ebuild,v 1.3 2003/04/26 05:36:58 strider Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.6-r2.ebuild,v 1.4 2003/08/05 18:53:42 vapier Exp $
-S=${WORKDIR}/jakarta-oro-${PV}
DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
-SRC_URI="mirror://apache/jakarta/oro/source/jakarta-oro-${PV}.tar.gz"
HOMEPAGE="http://jakarta.apache.org/oro/index.html"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- jikes? ( >=dev-java/jikes-1.17 )"
-REDEPND=">=virtual/jdk-1.3"
+SRC_URI="mirror://apache/jakarta/oro/source/jakarta-oro-${PV}.tar.gz"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jdk-1.3"
+
+S=${WORKDIR}/jakarta-oro-${PV}
+
src_compile() {
local myc
@@ -29,14 +32,11 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
mv jakarta-oro*.jar oro.jar
dojar oro.jar || die "Failed Installing"
dodoc BUGS CHANGES COMPILE CONTRIBUTORS README STYLE TODO
dohtml *.html
- if [ -n "`use doc`" ] ; then
- dodir /usr/share/doc/${P}
- dohtml -r docs/
- fi
+ [ -n "`use doc`" ] && dohtml -r docs/
}
diff --git a/dev-java/oro/oro-2.0.7.ebuild b/dev-java/oro/oro-2.0.7.ebuild
index 2ded54566df3..8b7ddb1f050f 100644
--- a/dev-java/oro/oro-2.0.7.ebuild
+++ b/dev-java/oro/oro-2.0.7.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.7.ebuild,v 1.3 2003/07/11 21:41:54 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.7.ebuild,v 1.4 2003/08/05 18:53:42 vapier Exp $
-S=${WORKDIR}/jakarta-oro-${PV}
DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
-SRC_URI="mirror://apache/jakarta/oro/source/jakarta-${PN}-${PV}.tar.gz"
HOMEPAGE="http://jakarta.apache.org/oro/index.html"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- jikes? ( >=dev-java/jikes-1.17 )"
-REDEPND=">=virtual/jdk-1.3"
+SRC_URI="mirror://apache/jakarta/oro/source/jakarta-${PN}-${PV}.tar.gz"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jdk-1.3"
+
+S=${WORKDIR}/jakarta-oro-${PV}
+
src_compile() {
local myc
@@ -29,14 +32,11 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
mv jakarta-oro*.jar oro.jar
dojar oro.jar || die "Failed Installing"
dodoc CHANGES COMPILE CONTRIBUTORS ISSUES LICENSE README STYLE TODO
dohtml *.html
- if [ -n "`use doc`" ] ; then
- dodir /usr/share/doc/${P}
- dohtml -r docs/
- fi
+ [ -n "`use doc`" ] && dohtml -r docs/
}
diff --git a/dev-java/xom/xom-1.0.14.ebuild b/dev-java/xom/xom-1.0.14.ebuild
index cc452e58f1b9..cbe53f26a03d 100644
--- a/dev-java/xom/xom-1.0.14.ebuild
+++ b/dev-java/xom/xom-1.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.0.14.ebuild,v 1.2 2003/05/26 08:49:16 absinthe Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.0.14.ebuild,v 1.3 2003/08/05 18:54:18 vapier Exp $
inherit java-pkg
@@ -8,15 +8,17 @@ inherit java-pkg
S=${WORKDIR}/XOM
XOMVER="xom-1.0d14"
DESCRIPTION="XOM is a new XML object model. It is a tree-based API for processing XML with Java that strives for correctness and simplicity."
-SRC_URI="http://cafeconleche.org/XOM/${XOMVER}.zip"
HOMEPAGE="http://cafeconleche.org/XOM/index.html"
-DEPEND=">=dev-java/ant-1.4"
-RDEPEND=">=virtual/jdk-1.2"
+SRC_URI="http://cafeconleche.org/XOM/${XOMVER}.zip"
+
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE="doc"
+DEPEND=">=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.2"
+
src_compile() {
local myc
cd ${WORKDIR}/XOM
@@ -24,8 +26,8 @@ src_compile() {
ANT_OPTS=${myc} ant jar || die "Failed Compiling"
}
-src_install () {
- mv ${WORKDIR}/XOM/build/${XOMVER}.jar xom.jar
+src_install() {
+ mv ${WORKDIR}/XOM/build/${XOMVER}.jar xom.jar
java-pkg_dojar xom.jar || die "Failed Installing"
dodoc Todo.txt
diff --git a/dev-lang/ghc-bin/ghc-bin-5.04.2-r1.ebuild b/dev-lang/ghc-bin/ghc-bin-5.04.2-r1.ebuild
index d40e3526149d..5888c85676ba 100644
--- a/dev-lang/ghc-bin/ghc-bin-5.04.2-r1.ebuild
+++ b/dev-lang/ghc-bin/ghc-bin-5.04.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.2-r1.ebuild,v 1.2 2003/07/11 22:14:07 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.2-r1.ebuild,v 1.3 2003/08/05 18:55:56 vapier Exp $
IUSE="opengl"
diff --git a/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild b/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild
index 34705ddf6e4a..f2c175ca2f6b 100644
--- a/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild
+++ b/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild,v 1.6 2003/04/06 06:40:38 george Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild,v 1.7 2003/08/05 18:55:56 vapier Exp $
IUSE="opengl"
diff --git a/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild b/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild
index 5d09177706e0..7442bb5bd889 100644
--- a/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild
+++ b/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild,v 1.3 2003/07/21 11:15:07 kosmikus Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.3.ebuild,v 1.4 2003/08/05 18:55:56 vapier Exp $
IUSE="opengl"
diff --git a/dev-lang/ghc-bin/ghc-bin-6.0.ebuild b/dev-lang/ghc-bin/ghc-bin-6.0.ebuild
index 43410f68a5ef..d300dea8a090 100644
--- a/dev-lang/ghc-bin/ghc-bin-6.0.ebuild
+++ b/dev-lang/ghc-bin/ghc-bin-6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.0.ebuild,v 1.2 2003/07/02 10:28:01 kosmikus Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.0.ebuild,v 1.3 2003/08/05 18:55:56 vapier Exp $
IUSE="opengl"
diff --git a/dev-lang/helium/helium-1.1.ebuild b/dev-lang/helium/helium-1.1.ebuild
index 168b74c0e6d8..fa5377df5730 100644
--- a/dev-lang/helium/helium-1.1.ebuild
+++ b/dev-lang/helium/helium-1.1.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/helium-1.1.ebuild,v 1.4 2003/07/11 22:14:07 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/helium-1.1.ebuild,v 1.5 2003/08/05 18:57:54 vapier Exp $
DESCRIPTION="Helium (for learning Haskell)"
+HOMEPAGE="http://www.cs.uu.nl/~afie/helium"
SRC_URI="http://www.cs.uu.nl/~afie/helium/distr/${P}-src.tar.gz
http://www.cs.uu.nl/~afie/helium/distr/Hint.jar"
-HOMEPAGE="http://www.cs.uu.nl/~afie/helium"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE="readline"
DEPEND="virtual/glibc
virtual/ghc
@@ -15,12 +20,6 @@ RDEPEND="virtual/glibc
dev-libs/gmp
readline? ( sys-libs/readline )"
-IUSE="readline"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~sparc"
-
src_unpack() {
unpack ${P}-src.tar.gz
diff --git a/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild b/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild
index dbae32272b9c..492cb21a7d9d 100644
--- a/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild
+++ b/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild,v 1.4 2003/07/11 22:14:08 aliz Exp $
-
-IUSE=""
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild,v 1.5 2003/08/05 18:56:23 vapier Exp $
MY_PV=${PV//./}
S=${WORKDIR}/stx
@@ -11,13 +9,14 @@ HOMEPAGE="http://www.exept.de/exept_99/english/welcomeFrame_smalltalk.html"
SRC_URI="mirror://gentoo/${PN}-common-${MY_PV}.tar.gz
mirror://gentoo/${PN}-linux-${MY_PV}.tar.gz"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86"
-DEPEND="virtual/glibc virtual/x11"
+DEPEND="virtual/glibc
+ virtual/x11"
-src_install () {
+src_install() {
dodir /opt
./INSTALL.sh -q -top ${D}/opt
@@ -37,5 +36,4 @@ src_install () {
echo "PATH=/opt/smalltalk/${PV}/bin" >> ${WORKDIR}/50smalltalkx
insinto /etc/env.d
doins ${WORKDIR}/50smalltalkx
-
}
diff --git a/dev-lang/stratego/stratego-0.8.1.ebuild b/dev-lang/stratego/stratego-0.8.1.ebuild
index 7eaf243d810b..09069342f0c1 100644
--- a/dev-lang/stratego/stratego-0.8.1.ebuild
+++ b/dev-lang/stratego/stratego-0.8.1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/stratego/stratego-0.8.1.ebuild,v 1.8 2003/02/13 10:29:50 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/stratego/stratego-0.8.1.ebuild,v 1.9 2003/08/05 18:57:11 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Stratego term-rewriting language"
+HOMEPAGE="http://www.stratego-language.org/"
SRC_URI="http://www.stratego-language.org/ftp/${P}.tar.gz"
-HOMEPAGE="http://www.stratego-language.org"
-DEPEND=">=dev-libs/aterm-1.6.7
- >=dev-libs/cpl-stratego-0.4"
-RDEPEND="$DEPEND"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
-IUSE=""
+
+DEPEND=">=dev-libs/aterm-1.6.7
+ >=dev-libs/cpl-stratego-0.4"
src_compile() {
# 2002-11-02, karltk@gentoo.org:
@@ -25,6 +24,6 @@ src_compile() {
DESTDIR=${D} || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}
diff --git a/dev-lang/stratego/stratego-0.8.ebuild b/dev-lang/stratego/stratego-0.8.ebuild
index bbf7b9957ce5..0d694ffc1efd 100644
--- a/dev-lang/stratego/stratego-0.8.ebuild
+++ b/dev-lang/stratego/stratego-0.8.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/stratego/stratego-0.8.ebuild,v 1.7 2003/07/11 22:14:08 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/stratego/stratego-0.8.ebuild,v 1.8 2003/08/05 18:57:11 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Stratego term-rewriting language"
+HOMEPAGE="http://www.stratego-language.org/"
SRC_URI="http://www.stratego-language.org/ftp/${P}.tar.gz"
-HOMEPAGE="http://www.stratego-language.org"
-DEPEND=">=dev-libs/aterm-1.6.7
- >=dev-libs/cpl-stratego-0.4"
-RDEPEND="$DEPEND"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
+DEPEND=">=dev-libs/aterm-1.6.7
+ >=dev-libs/cpl-stratego-0.4"
+
src_compile() {
./configure \
--host=${CHOST} \
@@ -22,6 +22,6 @@ src_compile() {
make DESTDIR=${D} || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}