summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/gnuconfig/ChangeLog11
-rw-r--r--sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch44
-rw-r--r--sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch16
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20131128.ebuild66
-rw-r--r--sys-devel/gnuconfig/gnuconfig-99999999.ebuild4
5 files changed, 130 insertions, 11 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index 6b590ce6be80..7681075dcd45 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.74 2013/12/21 09:25:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.75 2013/12/21 09:26:15 vapier Exp $
+
+*gnuconfig-20131128 (21 Dec 2013)
+
+ 21 Dec 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/99999999/0002-Add-x32-support-to-config.guess.patch,
+ +gnuconfig-20131128.ebuild,
+ files/99999999/0002-add-ps2-targets-to-config.sub.patch,
+ gnuconfig-99999999.ebuild:
+ Version bump.
21 Dec 2013; Mike Frysinger <vapier@gentoo.org> gnuconfig-20130516.ebuild:
Stabilize for all.
diff --git a/sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch b/sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch
new file mode 100644
index 000000000000..0e085f70ef85
--- /dev/null
+++ b/sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch
@@ -0,0 +1,44 @@
+From c5e163ea6346538d9f5c6c111fd865e92eeb491d Mon Sep 17 00:00:00 2001
+From: "H.J. Lu" <hongjiu.lu@intel.com>
+Date: Fri, 20 Dec 2013 14:36:01 -0500
+Subject: [PATCH] Add x32 support to config.guess
+
+GCC on Linux/x86-64 may be configured for x32:
+
+https://sites.google.com/site/x32abi/
+
+by default and the Linux/x32 target should be x86_64-VENDOR-linux-gnux32.
+This patch adds x32 support to config.guess. OK to install?
+
+URL: http://gcc.gnu.org/ml/gcc-patches/2012-08/msg01083.html
+---
+ config.guess | 13 ++++++++++++-
+ 1 file changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/config.guess b/config.guess
+index 9afd676..8b26ecf 100755
+--- a/config.guess
++++ b/config.guess
+@@ -1020,7 +1020,18 @@ EOF
+ echo ${UNAME_MACHINE}-dec-linux-${LIBC}
+ exit ;;
+ x86_64:Linux:*:*)
+- echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
++ eval $set_cc_for_build
++ X86_64_ABI=
++ # If there is a compiler, see if it is configured for 32-bit objects.
++ if [ "$CC_FOR_BUILD" != 'no_compiler_found' ]; then
++ if (echo '#ifdef __ILP32__'; echo IS_X32; echo '#endif') | \
++ (CCOPTS= $CC_FOR_BUILD -E - 2>/dev/null) | \
++ grep IS_X32 >/dev/null
++ then
++ X86_64_ABI=x32
++ fi
++ fi
++ echo x86_64-unknown-linux-gnu${X86_64_ABI}
+ exit ;;
+ xtensa*:Linux:*:*)
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
+--
+1.8.4.3
+
diff --git a/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
index 5e2da82ac70b..3b124379ab83 100644
--- a/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
+++ b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
@@ -1,26 +1,26 @@
-From 498d79139147953da13db30afc594ede214543d9 Mon Sep 17 00:00:00 2001
+From dc0922f791c29fc16340de97b0318e7573d57a32 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Thu, 9 Oct 2008 15:51:35 -0400
-Subject: [PATCH 2/2] add ps2 targets to config.sub
+Subject: [PATCH] add ps2 targets to config.sub
---
config.sub | 22 ++++++++++++++++++++--
1 file changed, 20 insertions(+), 2 deletions(-)
diff --git a/config.sub b/config.sub
-index 707e9e2..de08881 100755
+index 61cb4bc..4ffb084 100755
--- a/config.sub
+++ b/config.sub
-@@ -262,7 +262,7 @@ case $basic_machine in
+@@ -258,7 +258,7 @@ case $basic_machine in
| be32 | be64 \
| bfin \
- | c4x | clipper \
+ | c4x | c8051 | clipper \
- | d10v | d30v | dlx | dsp16xx \
+ | d10v | d30v | dlx | dsp16xx | dvp \
| epiphany \
| fido | fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
-@@ -812,6 +812,24 @@ case $basic_machine in
+@@ -810,6 +810,24 @@ case $basic_machine in
basic_machine=m68k-atari
os=-mint
;;
@@ -45,7 +45,7 @@ index 707e9e2..de08881 100755
mips3*-*)
basic_machine=`echo $basic_machine | sed -e 's/mips3/mips64/'`
;;
-@@ -1374,7 +1392,7 @@ case $os in
+@@ -1372,7 +1390,7 @@ case $os in
| -uxpv* | -beos* | -mpeix* | -udk* \
| -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
| -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
@@ -55,5 +55,5 @@ index 707e9e2..de08881 100755
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
--
-1.8.0.2
+1.8.4.3
diff --git a/sys-devel/gnuconfig/gnuconfig-20131128.ebuild b/sys-devel/gnuconfig/gnuconfig-20131128.ebuild
new file mode 100644
index 000000000000..26734d0b0489
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20131128.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20131128.ebuild,v 1.1 2013/12/21 09:26:15 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git
+ http://git.savannah.gnu.org/r/config.git"
+
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} ./* || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-2_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}
diff --git a/sys-devel/gnuconfig/gnuconfig-99999999.ebuild b/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
index cf798dd110d6..a74f9831878b 100644
--- a/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
+++ b/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-99999999.ebuild,v 1.11 2013/05/16 15:15:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-99999999.ebuild,v 1.12 2013/12/21 09:26:15 vapier Exp $
EAPI="2"
@@ -33,7 +33,7 @@ maint_pkg_create() {
cp "${FILESDIR}"/${PV}/*.patch . || die
local tar="${T}/gnuconfig-${ver}.tar.bz2"
- tar -jcf ${tar} . || die "creating tar failed"
+ tar -jcf ${tar} ./* || die "creating tar failed"
einfo "Packaged tar now available:"
einfo "$(du -b ${tar})"
}