summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog6
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-3.9-64bit.patch13
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-3.9.ebuild5
3 files changed, 22 insertions, 2 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 45263842d859..c4668bdb79ee 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.30 2004/08/31 03:07:28 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.31 2004/09/09 22:14:28 kugelfang Exp $
+
+ 10 Sep 2004; Danny van Dyk <kugelfang@gentoo.org>
+ +files/rxvt-unicode-3.9-64bit.patch, rxvt-unicode-3.9.ebuild:
+ Fixed BUG #59587.
30 Aug 2004; Tom Gall <tgall@gentoo.org> rxvt-unicode-3.0.ebuild:
stable on ppc64, bug #61755
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-3.9-64bit.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-3.9-64bit.patch
new file mode 100644
index 000000000000..88fbf4b15447
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/rxvt-unicode-3.9-64bit.patch
@@ -0,0 +1,13 @@
+--- src/screen.C.old 2004-09-09 23:55:29.244672496 +0200
++++ src/screen.C 2004-09-09 23:57:44.777068440 +0200
+@@ -3493,7 +3493,9 @@
+ else if (rq.target == xa[XA_TIMESTAMP] && selection.text)
+ {
+ XChangeProperty (display->display, rq.requestor, rq.property, XA_INTEGER,
+- (8 * sizeof (Time)), PropModeReplace,
++ /* This patch allows selecting text w/ the mouse on 64bit systems.
++ (8 * sizeof (Time)), PropModeReplace, */
++ (32), PropModeReplace,
+ (unsigned char *)&selection_time, 1);
+ ev.property = rq.property;
+ }
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-3.9.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-3.9.ebuild
index c42301ed6317..230b6d9110b7 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-3.9.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-3.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-3.9.ebuild,v 1.2 2004/09/02 16:47:28 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-3.9.ebuild,v 1.3 2004/09/09 22:14:28 kugelfang Exp $
+
+inherit 64-bit eutils
IUSE="xgetdefault"
@@ -23,6 +25,7 @@ src_unpack() {
sed -i -e \
"s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
doc/Makefile.in
+ 64-bit && epatch ${FILESDIR}/${P}-64bit.patch
}
src_compile() {