summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/patch/ChangeLog7
-rw-r--r--sys-devel/patch/patch-2.5.9-r1.ebuild10
2 files changed, 11 insertions, 6 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index 2fa66509603b..016d8dc3b295 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/patch
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.30 2005/04/01 17:12:45 agriffis Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.31 2005/05/07 09:39:40 vapier Exp $
+
+ 07 May 2005; Mike Frysinger <vapier@gentoo.org> patch-2.5.9-r1.ebuild:
+ Install as gpatch on non-GNU systems #91560.
01 Apr 2005; Aron Griffis <agriffis@gentoo.org> patch-2.5.9-r1.ebuild:
stable on ia64
diff --git a/sys-devel/patch/patch-2.5.9-r1.ebuild b/sys-devel/patch/patch-2.5.9-r1.ebuild
index e4abf55f99fd..c64a61cb5d0e 100644
--- a/sys-devel/patch/patch-2.5.9-r1.ebuild
+++ b/sys-devel/patch/patch-2.5.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9-r1.ebuild,v 1.6 2005/04/01 17:12:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9-r1.ebuild,v 1.7 2005/05/07 09:39:40 vapier Exp $
inherit flag-o-matic eutils
@@ -19,8 +19,8 @@ DEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-deb-cr.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-deb-cr.patch
}
src_compile() {
@@ -28,7 +28,9 @@ src_compile() {
append-flags -DLINUX -D_XOPEN_SOURCE=500
use static && append-ldflags -static
- ac_cv_sys_long_file_names=yes econf || die
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ ac_cv_sys_long_file_names=yes econf ${myconf} || die
emake || die "emake failed"
}