summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/smartmontools/ChangeLog8
-rw-r--r--sys-apps/smartmontools/Manifest4
-rw-r--r--sys-apps/smartmontools/files/digest-smartmontools-5.1.91
-rw-r--r--sys-apps/smartmontools/smartmontools-5.1.9.ebuild36
4 files changed, 46 insertions, 3 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index d4cbf97cc989..0cc3ef591681 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.3 2003/02/12 09:08:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.4 2003/04/14 23:38:47 mholzer Exp $
+
+*smartmontools-5.1.9 (15 Apr 2003)
+
+ 15 Apr 2003; Martin Holzer <mholzer@gentoo.org> Manifest,
+ smartmontools-5.1.9.ebuild:
+ Version bumped.
30 Jan 2002; Christian Birchinger <joker@gentoo.org> :
Added sparc keyword.
diff --git a/sys-apps/smartmontools/Manifest b/sys-apps/smartmontools/Manifest
index 04aaaffeb5b1..5100ab54f55a 100644
--- a/sys-apps/smartmontools/Manifest
+++ b/sys-apps/smartmontools/Manifest
@@ -1,6 +1,6 @@
-MD5 95334c4a1f6c64c12d0ba77ff689b8a9 ChangeLog 621
+MD5 d0926b72722951ee07bc88c9c7b9f7b1 ChangeLog 622
MD5 074069c5166bba1996556eed87872081 smartmontools-5.0.45.ebuild 960
-MD5 36a8ed618ed933830734c1e19ed1a9c6 smartmontools-5.1.9.ebuild 1002
+MD5 33404d5ea8a3edc59ea4a991557ac34c smartmontools-5.1.9.ebuild 1002
MD5 274bf91846f51fc5e93f303e5d4710f9 files/smartd.rc 518
MD5 5dafe6c5d2381ddd1e48877419a22372 files/digest-smartmontools-5.1.9 71
MD5 432ca1c6b0ccb2ce8c44f223aebd61af files/digest-smartmontools-5.0.45 71
diff --git a/sys-apps/smartmontools/files/digest-smartmontools-5.1.9 b/sys-apps/smartmontools/files/digest-smartmontools-5.1.9
new file mode 100644
index 000000000000..d3b8acd39173
--- /dev/null
+++ b/sys-apps/smartmontools/files/digest-smartmontools-5.1.9
@@ -0,0 +1 @@
+MD5 86ddd19b574d31cf420c528d94308ffc smartmontools-5.1-9.tar.gz 113194
diff --git a/sys-apps/smartmontools/smartmontools-5.1.9.ebuild b/sys-apps/smartmontools/smartmontools-5.1.9.ebuild
new file mode 100644
index 000000000000..4b8655eda6c5
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.1.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.1.9.ebuild,v 1.1 2003/04/14 23:38:47 mholzer Exp $
+
+MAJ_PV=${PV:0:3}
+MIN_PV=${PV:4:6}
+
+MY_P="${PN}-${MAJ_PV}-${MIN_PV}"
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dosbin smart{ctl,d}
+ doman *.8 *.5
+ dodoc CHANGELOG WARNINGS README TODO VERSION smartd.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/smartd.rc smartd
+}
+
+pkg_postinst() {
+ einfo "You can find an example smartd.conf file in"
+ einfo "/usr/share/doc/${PF}/smartd.conf.gz"
+ einfo "Just place it in /etc/ as smartd.conf"
+}