summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-pda/pilot-link/ChangeLog9
-rw-r--r--app-pda/pilot-link/files/digest-pilot-link-0.12.33
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.3-java-install.patch24
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.3-png.patch78
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3.ebuild95
5 files changed, 208 insertions, 1 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index 6c97d66233bd..470daa989052 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/pilot-link
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.30 2007/10/07 17:15:16 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.31 2007/12/19 21:09:49 philantrop Exp $
+
+*pilot-link-0.12.3 (19 Dec 2007)
+
+ 19 Dec 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/pilot-link-0.12.3-java-install.patch,
+ +files/pilot-link-0.12.3-png.patch, +pilot-link-0.12.3.ebuild:
+ Version bump as per bug 202383.
07 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+files/pilot-link-0.12.2-werror_194921.patch, pilot-link-0.11.8.ebuild,
diff --git a/app-pda/pilot-link/files/digest-pilot-link-0.12.3 b/app-pda/pilot-link/files/digest-pilot-link-0.12.3
new file mode 100644
index 000000000000..f37edcbcb10e
--- /dev/null
+++ b/app-pda/pilot-link/files/digest-pilot-link-0.12.3
@@ -0,0 +1,3 @@
+MD5 257124484d50552679c53cae8e118aa3 pilot-link-0.12.3.tar.bz2 960812
+RMD160 938f367a38572d456b37e62ab0d309139b50403b pilot-link-0.12.3.tar.bz2 960812
+SHA256 f5ed3f1d70349ff5ef95e6d1aa5b2ea9ad4b4d720e7d83cacc1003a950d4c476 pilot-link-0.12.3.tar.bz2 960812
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.3-java-install.patch b/app-pda/pilot-link/files/pilot-link-0.12.3-java-install.patch
new file mode 100644
index 000000000000..65d99d0be99d
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.3-java-install.patch
@@ -0,0 +1,24 @@
+diff -Naur pilot-link-0.12.3.orig/bindings/Java/Makefile.am pilot-link-0.12.3/bindings/Java/Makefile.am
+--- pilot-link-0.12.3.orig/bindings/Java/Makefile.am 2007-11-09 15:42:41.000000000 +0100
++++ pilot-link-0.12.3/bindings/Java/Makefile.am 2007-12-19 21:08:01.000000000 +0100
+@@ -81,20 +81,6 @@
+ java_pisock: java_compile java_lib java_jar
+
+ install: all
+- ARCH=""; \
+- for a in i386 amd64 ppc; do \
+- if [ -e ${JAVABASE}/jre/lib/$${a} ]; then \
+- ARCH="$${a}"; \
+- break; \
+- fi; \
+- done; \
+- if [ -n "$${ARCH}" ]; then \
+- echo "Unknown architecture. Copy lipijsock.so to ${JAVABASE}/jre/lib/ARCH/"; \
+- else \
+- mkdir -p "$(DESTDIR)${JAVABASE}/jre/lib/$${ARCH}" && \
+- cp libjpisock.so "$(DESTDIR)${JAVABASE}/jre/lib/$${ARCH}"; \
+- echo "done."; \
+- fi
+
+ test: install
+ ${JAVABASE}/bin/java test ${PORT}
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.3-png.patch b/app-pda/pilot-link/files/pilot-link-0.12.3-png.patch
new file mode 100644
index 000000000000..4de7b3a46b75
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.3-png.patch
@@ -0,0 +1,78 @@
+diff -Naur pilot-link-0.12.3.orig/configure.ac pilot-link-0.12.3/configure.ac
+--- pilot-link-0.12.3.orig/configure.ac 2007-11-09 20:36:37.000000000 +0100
++++ pilot-link-0.12.3/configure.ac 2007-12-19 21:38:27.000000000 +0100
+@@ -225,42 +225,44 @@
+ AC_ARG_WITH(libpng,
+ [ --with-libpng Prefix where libpng is installed])
+
+- case $with_libpng in
+- /*)
+- PNG_CFLAGS="-I$withval/include"
+- PNG_LIBS="-L$withval/lib"
+- ;;
+- esac
++ if test "x$with_libpng" != "xno"; then
+
+- save_CFLAGS="$CFLAGS"
+- save_CPPFLAGS="$CPPFLAGS"
+- save_LDFLAGS="$LDFLAGS"
+- CFLAGS="$CFLAGS $PNG_CFLAGS"
+- CPPFLAGS="$CPPFLAGS $PNG_CFLAGS"
+- LDFLAGS="$LDFLAGS $PNG_LIBS"
+-
+- AC_CHECK_LIB(png, main, [have_png=yes; PNG_LIBS="$PNG_LIBS -lpng"],[have_png=no],[-lm])
+- if test "$have_png" = yes; then
+- AC_CHECK_HEADER(png.h, , have_png=no)
++ case $with_libpng in
++ /*)
++ PNG_CFLAGS="-I$withval/include"
++ PNG_LIBS="-L$withval/lib"
++ ;;
++ esac
++
++ save_CFLAGS="$CFLAGS"
++ save_CPPFLAGS="$CPPFLAGS"
++ save_LDFLAGS="$LDFLAGS"
++ CFLAGS="$CFLAGS $PNG_CFLAGS"
++ CPPFLAGS="$CPPFLAGS $PNG_CFLAGS"
++ LDFLAGS="$LDFLAGS $PNG_LIBS"
++
++ AC_CHECK_LIB(png, main, [have_png=yes; PNG_LIBS="$PNG_LIBS -lpng"],[have_png=no],[-lm])
+ if test "$have_png" = yes; then
+- AC_MSG_CHECKING(for png setjmp support)
+- AC_EGREP_CPP(yes,
+- [#include <png.h>
+- #ifdef PNG_SETJMP_SUPPORTED
+- yes
+- #endif], , have_png=no)
+- AC_MSG_RESULT($have_png)
++ AC_CHECK_HEADER(png.h, , have_png=no)
+ if test "$have_png" = yes; then
+- AC_DEFINE(HAVE_PNG, 1, [Define if we have PNG support])
+- have_png=yes
+- msg_png=yes
++ AC_MSG_CHECKING(for png setjmp support)
++ AC_EGREP_CPP(yes,
++ [#include <png.h>
++ #ifdef PNG_SETJMP_SUPPORTED
++ yes
++ #endif], , have_png=no)
++ AC_MSG_RESULT($have_png)
++ if test "$have_png" = yes; then
++ AC_DEFINE(HAVE_PNG, 1, [Define if we have PNG support])
++ have_png=yes
++ msg_png=yes
++ fi
+ fi
+ fi
++ CFLAGS="$save_CFLAGS"
++ CPPFLAGS="$save_CPPFLAGS"
++ LDFLAGS="$save_LDFLAGS"
+ fi
+-
+- CFLAGS="$save_CFLAGS"
+- CPPFLAGS="$save_CPPFLAGS"
+- LDFLAGS="$save_LDFLAGS"
+ else
+ have_png="none"
+ PNG_CFLAGS=
diff --git a/app-pda/pilot-link/pilot-link-0.12.3.ebuild b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
new file mode 100644
index 000000000000..0da9c146929b
--- /dev/null
+++ b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3.ebuild,v 1.1 2007/12/19 21:09:49 philantrop Exp $
+
+inherit perl-module java-pkg-opt-2 eutils autotools
+
+DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
+HOMEPAGE="http://www.pilot-link.org/"
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="perl java python png readline threads bluetooth usb debug"
+
+BOTH_DEPEND="virtual/libiconv
+ >=sys-libs/ncurses-5.6-r1
+ >=dev-libs/popt-1.10.7
+ perl? ( >=dev-lang/perl-5.8.8-r2 )
+ python? ( >=dev-lang/python-2.4.4-r4 )
+ png? ( >=media-libs/libpng-1.2.18-r1 )
+ readline? ( >=sys-libs/readline-5.2_p4 )
+ usb? ( >=dev-libs/libusb-0.1.12 )
+ bluetooth? ( >=net-wireless/bluez-libs-3.10 )"
+
+DEPEND="${BOTH_DEPEND}
+ java? ( >=virtual/jdk-1.4 )"
+
+RDEPEND="${BOTH_DEPEND}
+ java? ( >=virtual/jre-1.4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fixing some broken configure switches and automagic deps.
+ epatch "${FILESDIR}/${PN}-0.12.2-readline.patch"
+ epatch "${FILESDIR}/${PN}-0.12.2-threads.patch"
+ epatch "${FILESDIR}/${P}-png.patch"
+
+ # Upstream's check for Werror was wrong. Fixes bug 194921.
+ epatch "${FILESDIR}/${PN}-0.12.2-werror_194921.patch"
+
+ # We install the Java bindings using the eclass functions so we disable
+ # their installation here.
+ use java && epatch "${FILESDIR}/${P}-java-install.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ # tcl/tk support is disabled as per upstream request.
+ econf \
+ --includedir=/usr/include/libpisock \
+ --enable-conduits \
+ --with-tcl=no \
+ --without-included-popt \
+ --disable-compile-werror \
+ $(use_enable threads) \
+ $(use_enable usb libusb) \
+ $(use_enable debug) \
+ $(use_with png libpng $(libpng-config --prefix)) \
+ $(use_with bluetooth bluez) \
+ $(use_with readline) \
+ $(use_with perl) \
+ $(use_with java) \
+ $(use_with python) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+ if use perl ; then
+ cd "${S}/bindings/Perl"
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS || die "installing docs failed"
+
+ if use java ; then
+ cd "${S}/bindings/Java"
+ java-pkg_newjar ${PN}.jar
+ java-pkg_doso libjpisock.so
+ fi
+
+ if use perl ; then
+ cd "${S}/bindings/Perl"
+ perl-module_src_install
+ fi
+}