summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/strace/ChangeLog7
-rw-r--r--dev-util/strace/files/digest-strace-4.5.71
-rw-r--r--dev-util/strace/strace-4.5.7.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index a79b10c60d46..530f81fe0411 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/strace
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.43 2004/08/07 22:35:34 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.44 2004/09/22 03:15:40 vapier Exp $
+
+*strace-4.5.7 (21 Sep 2004)
+
+ 21 Sep 2004; Mike Frysinger <vapier@gentoo.org> +strace-4.5.7.ebuild:
+ Version bump.
07 Aug 2004; Tom Martin <slarti@gentoo.org> strace-4.4.94.ebuild:
Typo in DESCRIPTION: usefull -> useful. Bug 59717.
diff --git a/dev-util/strace/files/digest-strace-4.5.7 b/dev-util/strace/files/digest-strace-4.5.7
new file mode 100644
index 000000000000..63c7ce36037e
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-4.5.7
@@ -0,0 +1 @@
+MD5 b1829d858b6cd7072f9b2fa9c17a2346 strace-4.5.7.tar.bz2 414738
diff --git a/dev-util/strace/strace-4.5.7.ebuild b/dev-util/strace/strace-4.5.7.ebuild
new file mode 100644
index 000000000000..a72f73ee23cf
--- /dev/null
+++ b/dev-util/strace/strace-4.5.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.7.ebuild,v 1.1 2004/09/22 03:15:40 vapier Exp $
+
+inherit flag-o-matic gnuconfig
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~arm ~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+
+ # Compile fails with -O3 on sparc but works on x86
+ if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
+ replace-flags -O[3-9] -O2
+ fi
+ filter-lfs-flags
+
+ use static && append-ldflags -static
+}
+
+src_install() {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace strace-graph || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}