summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/uevt/ChangeLog9
-rw-r--r--sys-apps/uevt/files/uevt-2.3-vala-0.24.patch13
-rw-r--r--sys-apps/uevt/uevt-2.3-r1.ebuild20
3 files changed, 33 insertions, 9 deletions
diff --git a/sys-apps/uevt/ChangeLog b/sys-apps/uevt/ChangeLog
index ace3b8e3aa52..261f7ebd1766 100644
--- a/sys-apps/uevt/ChangeLog
+++ b/sys-apps/uevt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/uevt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/uevt/ChangeLog,v 1.16 2014/05/26 19:54:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uevt/ChangeLog,v 1.17 2014/06/04 09:04:18 ssuominen Exp $
+
+ 04 Jun 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/uevt-2.3-vala-0.24.patch, uevt-2.3-r1.ebuild:
+ Support >=dev-lang/vala-0.24.0 wrt #509512 by Alexandre Rostovtsev. Prefer
+ sys-power/upower-pm-utils over sys-power/upower because that's the only way to
+ get Hibernate and Suspend support in this version of UEvt. However, don't
+ force it because the power management features are optional.
26 May 2014; Samuli Suominen <ssuominen@gentoo.org> uevt-2.3-r1.ebuild:
Fix dependencies to allow sys-power/upower-pm-utils.
diff --git a/sys-apps/uevt/files/uevt-2.3-vala-0.24.patch b/sys-apps/uevt/files/uevt-2.3-vala-0.24.patch
new file mode 100644
index 000000000000..9cb0917b180f
--- /dev/null
+++ b/sys-apps/uevt/files/uevt-2.3-vala-0.24.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/509512
+
+--- src/uevt-notify.vala
++++ src/uevt-notify.vala
+@@ -51,7 +51,7 @@
+ if(notify != true)
+ return;
+
+- Notification notif = new Notification(head, Markup.escape_text(body), icon);
++ Notify.Notification notif = new Notify.Notification(head, Markup.escape_text(body), icon);
+
+ try {
+ notif.show();
diff --git a/sys-apps/uevt/uevt-2.3-r1.ebuild b/sys-apps/uevt/uevt-2.3-r1.ebuild
index baf8e62f7475..f3b5e34be104 100644
--- a/sys-apps/uevt/uevt-2.3-r1.ebuild
+++ b/sys-apps/uevt/uevt-2.3-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/uevt/uevt-2.3-r1.ebuild,v 1.7 2014/05/26 19:54:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uevt/uevt-2.3-r1.ebuild,v 1.8 2014/06/04 09:04:18 ssuominen Exp $
EAPI=5
VALA_MIN_API_VERSION="0.16"
-VALA_MAX_API_VERSION="0.22"
inherit eutils vala
DESCRIPTION="UPower/UDisks Event, a lightweight desktop-independent power and disk manager"
@@ -16,15 +15,13 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-#TODO FIXME: Does this release work with >=sys-power/upower-0.99 API?
-#If not, adjust dependencies to:
-#|| ( <sys-power/upower-0.99 sys-power/upower-pm-utils ) )
COMMON_DEPEND=">=dev-libs/glib-2.28
x11-libs/gtk+:2
>=x11-libs/libnotify-0.7"
+# Prefer sys-power/upower-pm-utils because there is no Hibernate/Suspend otherwise
RDEPEND="${COMMON_DEPEND}
- >=sys-fs/udisks-1.0.4-r5:0
- || ( >=sys-power/upower-0.9.21 sys-power/upower-pm-utils )"
+ >=sys-fs/udisks-1.0.5:0
+ || ( sys-power/upower-pm-utils >=sys-power/upower-0.9.23 )"
DEPEND="${COMMON_DEPEND}
$(vala_depend)
dev-util/intltool
@@ -39,7 +36,9 @@ pkg_setup() {
src_prepare() {
# http://git.sleipnir.fr/uevt/commit/?id=69d2f45e234190fbfb37745ea05ab88547a3de96
- epatch "${FILESDIR}"/${P}-support_for_more_than_one_CPU.patch
+ epatch \
+ "${FILESDIR}"/${P}-support_for_more_than_one_CPU.patch \
+ "${FILESDIR}"/${P}-vala-0.24.patch
# See http://bugs.gentoo.org/ wrt #428438
echo src/configurator.c >> po/POTFILES.skip
@@ -47,3 +46,8 @@ src_prepare() {
vala_src_prepare
}
+
+pkg_postinst() {
+ has_version '>=sys-power/upower-0.99.0' && \
+ ewarn "This version of UEvt doesn't support Hibernate/Suspend with UPower >= 0.99.0"
+}