summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus/clamav/clamav-0.80.ebuild')
-rw-r--r--app-antivirus/clamav/clamav-0.80.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/app-antivirus/clamav/clamav-0.80.ebuild b/app-antivirus/clamav/clamav-0.80.ebuild
deleted file mode 100644
index 92aa7556cfde..000000000000
--- a/app-antivirus/clamav/clamav-0.80.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.80.ebuild,v 1.13 2005/02/06 18:01:35 corsair Exp $
-
-inherit eutils flag-o-matic
-
-#MY_P="${PN}-0.80rc3"
-MY_P="${P}"
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/clamav/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc sparc amd64 hppa ~alpha ppc64"
-IUSE="milter crypt selinux"
-
-DEPEND="virtual/libc
- crypt? ( >=dev-libs/gmp-4.1.2 )"
-RDEPEND="selinux? ( sec-policy/selinux-clamav )"
-PROVIDE="virtual/antivirus"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- enewgroup clamav
- enewuser clamav -1 /bin/false /dev/null clamav
- pwconv || die
-}
-
-src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-lfs-flags
-
- local myconf
- use milter && myconf="--enable-milter"
- econf ${myconf} --with-dbdir=/var/lib/clamav || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS BUGS NEWS README ChangeLog TODO FAQ INSTALL
- exeinto /etc/init.d ; newexe ${FILESDIR}/clamd.rc clamd
- insinto /etc/conf.d ; newins ${FILESDIR}/clamd.conf clamd
- dodoc ${FILESDIR}/clamav-milter.README.gentoo
-}
-
-pkg_postinst() {
- einfo "NOTE: As of clamav-0.80, the config file for clamd is no longer"
- einfo " /etc/clamav.conf, but /etc/clamd.conf. Adjust your"
- einfo " configuration accordingly before (re)starting clamd."
- einfo ""
- ewarn "Warning: clamd and/or freshclam have not been restarted."
- ewarn "You should restart them with: /etc/init.d/clamd restart"
- einfo ""
- if use milter ; then
- einfo "For simple instructions howto setup the clamav-milter..."
- einfo ""
- einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
- fi
-}