summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus/clamav/clamav-0.84.ebuild')
-rw-r--r--app-antivirus/clamav/clamav-0.84.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/app-antivirus/clamav/clamav-0.84.ebuild b/app-antivirus/clamav/clamav-0.84.ebuild
deleted file mode 100644
index 907a3295df16..000000000000
--- a/app-antivirus/clamav/clamav-0.84.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.84.ebuild,v 1.1 2005/05/01 18:09:54 ticho Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="http://www.clamav.net/"
-SRC_URI="mirror://sourceforge/clamav/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~hppa ~alpha ~ppc64 ~ia64"
-IUSE="crypt milter selinux"
-
-DEPEND="virtual/libc
- crypt? ( >=dev-libs/gmp-4.1.2 )
- milter? ( mail-mta/sendmail )
- >=sys-libs/zlib-1.2.1-r3
- >=net-misc/curl-7.10.0
- net-dns/libidn"
-RDEPEND="selinux? ( sec-policy/selinux-clamav )"
-PROVIDE="virtual/antivirus"
-
-pkg_setup() {
- if use milter; then
- if ! built_with_use mail-mta/sendmail milter; then
- ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
- ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
- ewarn "this flag for clamav as well to disable milter support."
- die "need milter-enabled sendmail"
- fi
- fi
- enewgroup clamav
- enewuser clamav -1 /bin/false /dev/null clamav
- pwconv || die
-}
-
-src_compile() {
- has_version =sys-libs/glibc-2.2* && filter-lfs-flags
-
- local myconf
-
- # we depend on fixed zlib, so we can disable this check to prevent redundant
- # warning (bug #61749)
- myconf="${myconf} --disable-zlib-vcheck"
-
- use milter && myconf="${myconf} --enable-milter"
- econf ${myconf} --with-dbdir=/var/lib/clamav || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
- newinitd ${FILESDIR}/clamd.rc clamd
- newconfd ${FILESDIR}/clamd.conf clamd
- dodoc ${FILESDIR}/clamav-milter.README.gentoo
-}
-
-pkg_postinst() {
- echo
- einfo "NOTE: As of clamav-0.80, the config file for clamd is no longer"
- einfo " /etc/clamav.conf, but /etc/clamd.conf. Adjust your"
- einfo " configuration accordingly before (re)starting clamd."
- echo
- ewarn "Warning: clamd and/or freshclam have not been restarted."
- ewarn "You should restart them with: /etc/init.d/clamd restart"
- echo
- if use milter ; then
- einfo "For simple instructions howto setup the clamav-milter..."
- einfo ""
- einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
- echo
- fi
-}