summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/arj/arj-3.10.21.ebuild')
-rw-r--r--app-arch/arj/arj-3.10.21.ebuild33
1 files changed, 31 insertions, 2 deletions
diff --git a/app-arch/arj/arj-3.10.21.ebuild b/app-arch/arj/arj-3.10.21.ebuild
index 4f0d2bda3d16..fca1d6b4f781 100644
--- a/app-arch/arj/arj-3.10.21.ebuild
+++ b/app-arch/arj/arj-3.10.21.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.21.ebuild,v 1.3 2005/01/01 11:41:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.21.ebuild,v 1.4 2005/01/01 22:12:53 aliz Exp $
-inherit gnuconfig eutils
+inherit gnuconfig eutils gcc
DESCRIPTION="Utility for opening arj archives"
HOMEPAGE="http://arj.sourceforge.net/"
@@ -17,6 +17,35 @@ RESTRICT="nostrip"
DEPEND="virtual/libc"
src_compile() {
+ if [ -x /usr/sbin/gcc-config ]
+ then
+ # Do we have a gcc that use the new layout and gcc-config ?
+ if /usr/sbin/gcc-config --get-current-profile &> /dev/null
+ then
+ export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
+
+ # Just recheck gcc version ...
+ if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
+ then
+ # See if we can get a gcc profile we know is proper ...
+ if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4 &> /dev/null
+ then
+ export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4):${PATH}"
+ export GCC_PROFILE="${CHOST}-3.3.4"
+ else
+ eerror "This build needs gcc-3.2 or gcc-3.3!"
+ eerror
+ eerror "Use gcc-config to change your gcc profile:"
+ eerror
+ eerror " # gcc-config $CHOST-3.3.4"
+ eerror
+ eerror "or whatever gcc version is relevant."
+ die
+ fi
+ fi
+ fi
+ fi
+
gnuconfig_update
cd ${S}/gnu