summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/ChangeLog5
-rw-r--r--app-arch/dpkg/dpkg-1.17.23.ebuild16
2 files changed, 18 insertions, 3 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 4342bfb37d16..c714e38598d3 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.310 2015/02/24 08:42:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.311 2015/02/24 22:31:44 vapier Exp $
+
+ 24 Feb 2015; Mike Frysinger <vapier@gentoo.org> dpkg-1.17.23.ebuild:
+ Add mips support.
24 Feb 2015; Agostino Sarubbo <ago@gentoo.org> dpkg-1.17.23.ebuild:
Stable for alpha, wrt bug #539648
diff --git a/app-arch/dpkg/dpkg-1.17.23.ebuild b/app-arch/dpkg/dpkg-1.17.23.ebuild
index 2970ce83f9df..7e9836615079 100644
--- a/app-arch/dpkg/dpkg-1.17.23.ebuild
+++ b/app-arch/dpkg/dpkg-1.17.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.23.ebuild,v 1.7 2015/02/24 08:42:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.23.ebuild,v 1.8 2015/02/24 22:31:44 vapier Exp $
EAPI=5
inherit eutils multilib autotools toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~m68k ppc ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
RDEPEND="
@@ -52,6 +52,18 @@ src_prepare() {
# installed, so no need to worry about hardcoding a temporary bash)
sed -i -e '1c\#!'"${BASH}" get-version || die
+ if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
+ # Debian targets use custom full tuples. Map the default one
+ # based on the ABI we're using.
+ local abi
+ if [[ ${ABI} == "n64" ]] ; then
+ abi="mips64"
+ else
+ abi="mipsn32"
+ fi
+ printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
+ fi
+
use nls && strip-linguas -i po
eautoreconf