summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/dump/dump-0.4.30.ebuild')
-rw-r--r--app-arch/dump/dump-0.4.30.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/app-arch/dump/dump-0.4.30.ebuild b/app-arch/dump/dump-0.4.30.ebuild
deleted file mode 100644
index 805ee98f85a8..000000000000
--- a/app-arch/dump/dump-0.4.30.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.30.ebuild,v 1.11 2003/02/13 05:53:41 vapier Exp $
-
-MY_P=${P/4./4b}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="Dump/restore ext2fs backup utilities"
-SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
-HOMEPAGE="http://dump.sourceforge.net/"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="x86 sparc "
-IUSE="readline static"
-
-DEPEND=">=sys-apps/e2fsprogs-1.27
- >=sys-apps/bzip2-1.0.2
- >=sys-libs/zlib-1.1.4
- sys-kernel/linux-headers
- readline? ( sys-libs/readline )"
-RDEPEND="sys-apps/star"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- if [ `use readline` ] ; then
- for i in configure configure.in
- do
- cp ${i} ${i}.orig
- sed "s:-ltermcap:-lncurses:g" \
- ${i}.orig > ${i}
- done
- fi
-}
-
-src_compile() {
- local myconf
-
- use readline \
- && myconf="--enable-readline" \
- || myconf="--disable-readline"
-
- use static \
- && myconf="${myconf} --enable-static" \
- || myconf="${myconf} --enable-shared"
-
- econf \
- --with-dumpdatespath=/etc/dumpdates \
- --with-binowner=root \
- --with-bingroup=root \
- --enable-largefile \
- ${myconf}
-
- emake || die
-}
-
-src_install() {
- einstall MANDIR=${D}/usr/share/man/man8
-
- dodoc CHANGES COPYRIGHT INSTALL KNOWNBUGS MAINTAINERS README \
- REPORTING-BUGS THANKS TODO
- dodoc -r examples/dump_on_cd
-}