summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unmakeself/unmakeself-1.1.ebuild')
-rw-r--r--app-arch/unmakeself/unmakeself-1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/unmakeself/unmakeself-1.1.ebuild b/app-arch/unmakeself/unmakeself-1.1.ebuild
new file mode 100644
index 000000000000..19320dc4856e
--- /dev/null
+++ b/app-arch/unmakeself/unmakeself-1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unmakeself/unmakeself-1.1.ebuild,v 1.1 2010/05/28 13:09:14 nyhm Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Makeself archive extractor"
+HOMEPAGE="http://www.freshports.org/archivers/unmakeself"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/libarchive[bzip2,zlib]"
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS=-larchive ${PN} || die "emake failed"
+}
+
+src_install() {
+ dobin unmakeself || die "dobin failed"
+}