summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/ebview/ebview-0.3.1-r1.ebuild')
-rw-r--r--app-dicts/ebview/ebview-0.3.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-dicts/ebview/ebview-0.3.1-r1.ebuild b/app-dicts/ebview/ebview-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..a1414ced38d5
--- /dev/null
+++ b/app-dicts/ebview/ebview-0.3.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ebview/ebview-0.3.1-r1.ebuild,v 1.1 2004/01/07 08:51:58 usata Exp $
+
+IUSE=""
+
+DESCRIPTION="EBView -- Electronic Book Viewer based on GTK+"
+HOMEPAGE="http://ebview.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ebview/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.57"
+RDEPEND=">=dev-libs/eb-3.3.4
+ >=x11-libs/gtk+-2.2
+ sys-devel/gettext"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-eb4-gentoo.diff
+
+ if has_version '>=sys-devel/gettext-0.12' ; then
+ cd ${S}/po
+ epatch ${FILESDIR}/${PN}-gettext-0.12-gentoo.diff
+ fi
+}
+
+src_compile() {
+
+ autoreconf || die
+
+ econf --with-eb-conf=/etc/eb.conf || die
+ emake || die
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog INSTALL* NEWS README TODO
+}