summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/bluefish/bluefish-0.7-r3.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-0.7-r3.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/app-editors/bluefish/bluefish-0.7-r3.ebuild b/app-editors/bluefish/bluefish-0.7-r3.ebuild
index 4cd16069516c..0b3b96427b02 100644
--- a/app-editors/bluefish/bluefish-0.7-r3.ebuild
+++ b/app-editors/bluefish/bluefish-0.7-r3.ebuild
@@ -1,43 +1,36 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.7-r3.ebuild,v 1.1 2002/11/14 17:06:11 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.7-r3.ebuild,v 1.2 2002/11/30 21:55:02 vapier Exp $
-IUSE="gnome nls perl"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Bluefish is a GTK HTML editor for the experienced web designer or programmer."
SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
HOMEPAGE="http://bluefish.openoffice.nl/"
+
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
SLOT="0"
+IUSE="gnome nls perl"
DEPEND="=x11-libs/gtk+-1.2*
>=media-libs/imlib-1.9.10-r1
- perl? ( sys-devel/perl )
- nls? ( sys-devel/gettext )"
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
src_compile() {
- local myconf=""
-
+ local myconf="--with-autocomplet"
use perl && myconf="${myconf} --with-perl"
use nls || myconf="${myconf} --disable-nls"
-
- econf \
- --with-autocomplet \
- ${myconf} || die "./configure failed"
+ econf ${myconf}
emake || die "Compilation failed"
-
}
-src_install () {
+src_install() {
einstall \
pkgdatadir=${D}/usr/share/bluefish \
- pixmapsdir=${D}/usr/share/pixmaps || die "Installation failed"
+ pixmapsdir=${D}/usr/share/pixmaps
- if [ "`use gnome`" ]
- then
+ if [ "`use gnome`" ] ; then
insinto /usr/share/gnome/apps/Development/
doins data/bluefish.desktop
fi