summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/dynamips')
-rw-r--r--app-emulation/dynamips/ChangeLog11
-rw-r--r--app-emulation/dynamips/dynamips-0.2.8_rc2-r1.ebuild (renamed from app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild)4
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch21
3 files changed, 25 insertions, 11 deletions
diff --git a/app-emulation/dynamips/ChangeLog b/app-emulation/dynamips/ChangeLog
index fbd3d596889d..29001f6eb90c 100644
--- a/app-emulation/dynamips/ChangeLog
+++ b/app-emulation/dynamips/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/dynamips
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dynamips/ChangeLog,v 1.2 2009/08/25 15:34:13 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dynamips/ChangeLog,v 1.3 2010/10/17 12:58:02 chainsaw Exp $
+
+*dynamips-0.2.8_rc2-r1 (17 Oct 2010)
+
+ 17 Oct 2010; <chainsaw@gentoo.org> -dynamips-0.2.8_rc2.ebuild,
+ +dynamips-0.2.8_rc2-r1.ebuild, files/dynamips-0.2.8_rc2-makefile.patch:
+ Instill LDFLAGS respect into upstream Makefile. Closes bug #338169 by
+ Diego Elio "Flameeyes" Pettenò.
25 Aug 2009; Raúl Porcel <armin76@gentoo.org> dynamips-0.2.8_rc2.ebuild:
Add ~x86 wrt #281315
diff --git a/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild b/app-emulation/dynamips/dynamips-0.2.8_rc2-r1.ebuild
index 4dd407603a04..1e81331ec5dc 100644
--- a/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild
+++ b/app-emulation/dynamips/dynamips-0.2.8_rc2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dynamips/dynamips-0.2.8_rc2.ebuild,v 1.2 2009/08/25 15:34:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dynamips/dynamips-0.2.8_rc2-r1.ebuild,v 1.1 2010/10/17 12:58:02 chainsaw Exp $
inherit eutils
diff --git a/app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch b/app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch
index 3262515eacaf..77d42bef90bb 100644
--- a/app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch
+++ b/app-emulation/dynamips/files/dynamips-0.2.8_rc2-makefile.patch
@@ -1,6 +1,6 @@
-diff -uNr dynamips-0.2.8-RC2.ORIG/Makefile dynamips-0.2.8-RC2/Makefile
---- dynamips-0.2.8-RC2.ORIG/Makefile 2009-08-07 17:24:11.000000000 +0100
-+++ dynamips-0.2.8-RC2/Makefile 2009-08-07 17:24:52.000000000 +0100
+diff -uNr dynamips-0.2.8-RC2.ORIG//Makefile dynamips-0.2.8-RC2/Makefile
+--- dynamips-0.2.8-RC2.ORIG//Makefile 2010-10-17 13:50:01.000000000 +0100
++++ dynamips-0.2.8-RC2/Makefile 2010-10-17 13:50:57.000000000 +0100
@@ -3,7 +3,7 @@
# Replace x86 by amd64 for a build on x86_64.
@@ -28,7 +28,7 @@ diff -uNr dynamips-0.2.8-RC2.ORIG/Makefile dynamips-0.2.8-RC2/Makefile
-DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" -DJIT_CPU=CPU_$(DYNAMIPS_ARCH) \
-DMIPS64_ARCH_INC_FILE=$(MIPS64_ARCH_INC_FILE) \
-DPPC32_ARCH_INC_FILE=$(PPC32_ARCH_INC_FILE) \
-@@ -215,8 +215,7 @@
+@@ -215,10 +215,9 @@
.PHONY: all
all: $(PROG) nvram_export
@@ -36,9 +36,12 @@ diff -uNr dynamips-0.2.8-RC2.ORIG/Makefile dynamips-0.2.8-RC2/Makefile
- $(LEX_C) $(C_OBJS) $(A_OBJS)
+$(PROG): $(LEX_C) $(C_OBJS) $(A_OBJS)
@echo "Linking $@"
- @$(CC) -o $@ $(C_OBJS) $(A_OBJS) $(LIBS)
+- @$(CC) -o $@ $(C_OBJS) $(A_OBJS) $(LIBS)
++ @$(CC) -o $@ $(C_OBJS) $(A_OBJS) $(LIBS) $(LDFLAGS)
-@@ -246,6 +245,8 @@
+ udp_send$(BIN_EXT): udp_send.c net.c crc.c
+ @echo "Linking $@"
+@@ -246,9 +245,11 @@
@echo "Building assembly definitions header file"
@./asmdefs
@@ -46,4 +49,8 @@ diff -uNr dynamips-0.2.8-RC2.ORIG/Makefile dynamips-0.2.8-RC2/Makefile
+
nvram_export$(BIN_EXT): nvram_export.c
@echo "Linking $@"
- @$(CC) -Wall $(CFLAGS) -o $@ nvram_export.c
+- @$(CC) -Wall $(CFLAGS) -o $@ nvram_export.c
++ @$(CC) -Wall $(CFLAGS) -o $@ nvram_export.c $(LDFLAGS)
+
+ install: $(PROG) nvram_export
+ @echo "Installing"