summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/ChangeLog7
-rw-r--r--app-emulation/vmware-modules/files/patches/010_all_makefile-vm-build-no-unused-warnings.patch11
-rw-r--r--app-emulation/vmware-modules/files/patches/020_all_epoll-def-warnings.patch18
3 files changed, 35 insertions, 1 deletions
diff --git a/app-emulation/vmware-modules/ChangeLog b/app-emulation/vmware-modules/ChangeLog
index b8c702ae0738..337d0e10bb09 100644
--- a/app-emulation/vmware-modules/ChangeLog
+++ b/app-emulation/vmware-modules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vmware-modules
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.14 2006/12/01 17:00:41 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.15 2006/12/17 01:51:25 vapier Exp $
+
+ 17 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/patches/010_all_makefile-vm-build-no-unused-warnings.patch,
+ +files/patches/020_all_epoll-def-warnings.patch:
+ Fix building with newer kernels #146004.
01 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
vmware-modules-1.0.0.15-r1.ebuild:
diff --git a/app-emulation/vmware-modules/files/patches/010_all_makefile-vm-build-no-unused-warnings.patch b/app-emulation/vmware-modules/files/patches/010_all_makefile-vm-build-no-unused-warnings.patch
new file mode 100644
index 000000000000..a0c47d52112d
--- /dev/null
+++ b/app-emulation/vmware-modules/files/patches/010_all_makefile-vm-build-no-unused-warnings.patch
@@ -0,0 +1,11 @@
+--- Makefile.kernel
++++ Makefile.kernel
+@@ -14,7 +14,7 @@
+ endif
+ vm_check_build = $(shell if $(CC) $(CPPFLAGS) $(CFLAGS) $(CFLAGS_KERNEL) \
+ $(EXTRA_CFLAGS) -Iinclude2/asm/mach-default -DKBUILD_BASENAME= \
+- -Werror -S -o /dev/null -xc $(1) \
++ -Werror -Wno-unused -S -o /dev/null -xc $(1) \
+ $(VMWARE_DEBUG_REDIRECT); then echo "$(2)"; else echo "$(3)"; fi)
+
+ CC_WARNINGS := -Wall -Wstrict-prototypes
diff --git a/app-emulation/vmware-modules/files/patches/020_all_epoll-def-warnings.patch b/app-emulation/vmware-modules/files/patches/020_all_epoll-def-warnings.patch
new file mode 100644
index 000000000000..c30d7c9c5e3e
--- /dev/null
+++ b/app-emulation/vmware-modules/files/patches/020_all_epoll-def-warnings.patch
@@ -0,0 +1,18 @@
+--- include/compat_wait.h
++++ include/compat_wait.h
+@@ -34,13 +34,13 @@
+ * 2.4.20-wolk4.0s.
+ */
+
+-#if VMW_HAVE_EPOLL // {
++#ifdef VMW_HAVE_EPOLL // {
+ #define compat_poll_wqueues struct poll_wqueues
+ #else // } {
+ #define compat_poll_wqueues poll_table
+ #endif // }
+
+-#if VMW_HAVE_EPOLL // {
++#ifdef VMW_HAVE_EPOLL // {
+
+ /* If prototype does not match, build will abort here */
+ extern void poll_initwait(compat_poll_wqueues *);