summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-chinese')
-rw-r--r--app-i18n/scim-chinese/ChangeLog10
-rw-r--r--app-i18n/scim-chinese/Manifest3
-rw-r--r--app-i18n/scim-chinese/files/digest-scim-chinese-0.2.11
-rw-r--r--app-i18n/scim-chinese/scim-chinese-0.2.1.ebuild66
4 files changed, 79 insertions, 1 deletions
diff --git a/app-i18n/scim-chinese/ChangeLog b/app-i18n/scim-chinese/ChangeLog
new file mode 100644
index 000000000000..62d41a65613e
--- /dev/null
+++ b/app-i18n/scim-chinese/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-i18n/scim-chinese
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-chinese/ChangeLog,v 1.1 2003/05/25 15:10:52 liquidx Exp $
+
+*scim-chinese-0.2.1 (25 May 2003)
+
+ 25 May 2003; Alastair Tse <liquidx@gentoo.org> scim-chinese-0.2.1.ebuild:
+ Initial ebuild. Distribution of this ebuild is allowed by the author, but
+ the binary must not be mirrored or used for commercial purposes.
+
diff --git a/app-i18n/scim-chinese/Manifest b/app-i18n/scim-chinese/Manifest
index e6fec17e475c..25ac193e082d 100644
--- a/app-i18n/scim-chinese/Manifest
+++ b/app-i18n/scim-chinese/Manifest
@@ -1,2 +1,3 @@
-MD5 ec89113f717253683f6b15185c8df93d scim-chinese-0.2.1.ebuild 625
+MD5 ec0910b91206e56881d37fdc5ca60005 scim-chinese-0.2.1.ebuild 1572
+MD5 e7c9042678ec32bb282ea24ad9cd7803 ChangeLog 480
MD5 711ddeffc04e00fc58aae25eb1f6e5d5 files/digest-scim-chinese-0.2.1 75
diff --git a/app-i18n/scim-chinese/files/digest-scim-chinese-0.2.1 b/app-i18n/scim-chinese/files/digest-scim-chinese-0.2.1
new file mode 100644
index 000000000000..4b39e70c8ecf
--- /dev/null
+++ b/app-i18n/scim-chinese/files/digest-scim-chinese-0.2.1
@@ -0,0 +1 @@
+MD5 dfcc5ac6aa0bfdd7289b18dfb041d6a4 scim-chinese-0.2.1-1.i586.rpm 1619241
diff --git a/app-i18n/scim-chinese/scim-chinese-0.2.1.ebuild b/app-i18n/scim-chinese/scim-chinese-0.2.1.ebuild
new file mode 100644
index 000000000000..7c41ac07e80c
--- /dev/null
+++ b/app-i18n/scim-chinese/scim-chinese-0.2.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-chinese/scim-chinese-0.2.1.ebuild,v 1.1 2003/05/25 15:10:52 liquidx Exp $
+
+DESCRIPTION="Smart Common Input Method (SCIM) Closed Source Pinyin Input Method"
+HOMEPAGE="http://www.gnuchina.org/~suzhe/scim/"
+SRC_URI="http://www.gnuchina.org/~suzhe/scim/scim-chinese/${P}-1.i586.rpm"
+
+LICENSE="scim-chinese"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+
+RDEPEND="virtual/x11
+ >=app-i18n/scim-0.4.1"
+
+DEPEND="${RDEPEND}
+ app-arch/rpm"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cd ${S}
+ rpm2cpio ${DISTDIR}/${A} | cpio -i --make-directories
+}
+
+src_compile() {
+ return
+}
+
+dosym_r() {
+ srcdir=$1
+ dstdir=$2
+
+ for x in `find ${D}${srcdir}`; do
+ dst=${dstdir}${x#$D$srcdir}
+ src=${x#$D}
+ einfo "Linking $src to $dst"
+ if [ ! -d "`dirname $D$dst`" ]; then
+ dodir ${dst}
+ fi
+ dosym $src $dst
+ done
+
+}
+
+src_install() {
+ # get installed scim version
+ SCIM_VER=$(scim -h | grep "Smart Common Input Method" | awk '{print $5}')
+
+ # install into /opt because this is binary-only
+ PREFIX=/opt/scim-chinese
+
+ cd ${S}
+ insinto ${PREFIX}/lib/scim-1.0/Server
+ doins usr/lib/scim-1.0/Server/*
+ dosym_r ${PREFIX}/lib/scim-1.0/Server /usr/lib/scim-1.0/${SCIM_VER}/Server
+
+ insinto ${PREFIX}/share/scim/chinese
+ doins usr/share/scim/chinese/*
+ dosym_r ${PREFIX}/share/scim/chinese /usr/share/scim/chinese
+
+ insinto /etc/gconf/schemas
+ doins etc/gconf/schemas/*
+ dodoc usr/share/doc/packages/scim-chinese-0.2.1/{AUTHORS,COPYING,README}
+}