summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/devtodo/devtodo-0.1.11-r1.ebuild')
-rw-r--r--app-misc/devtodo/devtodo-0.1.11-r1.ebuild59
1 files changed, 14 insertions, 45 deletions
diff --git a/app-misc/devtodo/devtodo-0.1.11-r1.ebuild b/app-misc/devtodo/devtodo-0.1.11-r1.ebuild
index 5fa28ca0e7c0..5a667175cb41 100644
--- a/app-misc/devtodo/devtodo-0.1.11-r1.ebuild
+++ b/app-misc/devtodo/devtodo-0.1.11-r1.ebuild
@@ -1,62 +1,31 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.11-r1.ebuild,v 1.2 2002/07/11 06:30:16 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.11-r1.ebuild,v 1.3 2002/07/25 16:55:21 seemant Exp $
-#Source directory; the dir where the sources can be found (automatically unpacked)
S=${WORKDIR}/${P}
-
-#Short one-line description
DESCRIPTION="A nice command line todo list for developers"
-
-#Point to any required sources; these will be automatically downloaded by Portage
SRC_URI="http://activelysecure.net/~alec/development/devtodo/0.1.11/${P}.tar.gz"
-
-#Homepage, not used by Portage directly but handy for developer reference
HOMEPAGE="http://activelysecure.net/~alec/development/devtodo/"
-#build-time dependencies
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.1
- >=sys-devel/gcc-2.95.3"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
-#run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/${P}.colourplain.patch
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}.colourplain.patch
}
src_compile() {
- #the "try" command will stop the build process if the specified command fails. Prefix critical
- #commands with "try"
- try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
- #Note the use of --infodir and --mandir, above. This is to make this package FHS 2.2-compliant
- #(/usr/share is used for info and man now).
-
- try make
- #emake (previously known as pmake) is a script that calls the standard GNU make with parallel
- #building options for speedier builds on SMP systems. Use emake first; it might not work. If
- #not, then replace the line above with:
-
- #try make
+ econf || die
+ make || die
}
src_install () {
- #you must *personally verify* that this trick doesn't install
- #anything outside of DESTDIR; do this by reading and understanding
- #the install part of the Makefiles. Also note that this will often
- #also work for autoconf stuff (usually much more often than DESTDIR,
- #which is actually quite rare.
-
- # try make prefix=${D}/usr install
-
- try make DESTDIR=${D} install
- #again, verify the Makefiles! We don't want anything falling outside
- #of ${D}.
-
- dodoc AUTHORS COPYING ChangeLog QuickStart README TODO
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog QuickStart README TODO
}
-