summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/workrave/workrave-1.4.0-r1.ebuild')
-rw-r--r--app-misc/workrave/workrave-1.4.0-r1.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/app-misc/workrave/workrave-1.4.0-r1.ebuild b/app-misc/workrave/workrave-1.4.0-r1.ebuild
index 4db5207a831a..365e5bbd4d7c 100644
--- a/app-misc/workrave/workrave-1.4.0-r1.ebuild
+++ b/app-misc/workrave/workrave-1.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/workrave/workrave-1.4.0-r1.ebuild,v 1.4 2003/10/24 13:02:20 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/workrave/workrave-1.4.0-r1.ebuild,v 1.5 2003/11/06 15:04:26 leonardop Exp $
IUSE="debug gnome nls xml2"
# Internal USE flags
@@ -27,10 +27,11 @@ RDEPEND=">=dev-libs/glib-2
gnome? ( >=gnome-base/libgnomeui-2
>=dev-cpp/libgnomeuimm-2
>=gnome-base/gnome-panel-2.0.10
- >=gnome-base/libbonobo-2 )
+ >=gnome-base/libbonobo-2
+ >=gnome-base/gconf-2 )
nls? ( sys-devel/gettext )
xml2? ( dev-libs/gdome2 )
- !xml2? ( >=gnome-base/gconf-2 )"
+ !xml2? ( !gnome? ( >=gnome-base/gconf-2 ) )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -54,12 +55,22 @@ src_compile() {
use debug && myconf="${myconf} --enable-debug"
use distribution || myconf="${myconf} --disable-distribution"
- use gnome || myconf="${myconf} --disable-gnome"
use nls || myconf="${myconf} --disable-nls"
use no-exercises || myconf="${myconf} --enable-exercises"
use no-experimental && myconf="${myconf} --disable-experimental"
- use xml2 && myconf="${myconf} --enable-xml" || \
+ use xml2 && myconf="${myconf} --enable-xml"
+
+ if [ `use gnome` ]
+ then
+ myconf="${myconf} --enable-gconf"
+ else
+ myconf="${myconf} --disable-gnome"
+ fi
+
+ if [ ! `use gnome` ] && [ ! `use xml2` ]
+ then
myconf="${myconf} --enable-gconf"
+ fi
econf ${myconf} || die