summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/xchm/xchm-0.8.7.ebuild')
-rw-r--r--app-misc/xchm/xchm-0.8.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/xchm/xchm-0.8.7.ebuild b/app-misc/xchm/xchm-0.8.7.ebuild
new file mode 100644
index 000000000000..9fff9dbfc376
--- /dev/null
+++ b/app-misc/xchm/xchm-0.8.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xchm/xchm-0.8.7.ebuild,v 1.1 2003/10/26 21:16:48 mholzer Exp $
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz
+ doc? ( mirror://sourceforge/xchm/${P}-doc.tar.gz )"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="doc"
+DEPEND=">=app-doc/chmlib-0.31
+ >=x11-libs/wxGTK-2.4.0"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc COPYING AUTHORS README
+
+ if [ "`use doc`" ]; then
+ cd ${S}"-doc"
+ dohtml html/*
+ fi
+}