summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/malsync/files/Makefile-pilot-link.diff')
-rw-r--r--app-pda/malsync/files/Makefile-pilot-link.diff25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-pda/malsync/files/Makefile-pilot-link.diff b/app-pda/malsync/files/Makefile-pilot-link.diff
new file mode 100644
index 000000000000..845ecb9616a7
--- /dev/null
+++ b/app-pda/malsync/files/Makefile-pilot-link.diff
@@ -0,0 +1,25 @@
+diff -urN malsync.orig/Makefile malsync/Makefile
+--- malsync.orig/Makefile 2003-05-30 19:42:14.000000000 -0400
++++ malsync/Makefile 2003-08-01 16:29:24.000000000 -0400
+@@ -15,10 +15,10 @@
+ endif
+
+ TREETOP = .
+-PILOT_LINK_DIR = $(TREETOP)/pilot-link-0.11.7
++PILOT_LINK_DIR = /usr/include/libpisock
+
+ CFLAGS = -Wall -g -DMALSYNC -I$(TREETOP)/mal/common \
+- -I$(TREETOP)/mal/client/common -I$(PILOT_LINK_DIR)/include \
++ -I$(TREETOP)/mal/client/common -I$(PILOT_LINK_DIR) \
+ -I$(TREETOP)/mal/client/unix
+
+ ifeq ($(PLAT),Darwin)
+@@ -73,7 +73,7 @@
+
+ $(TARGET): $(OBJS)
+ $(CC) $(DYNLINK) $(CFLAGS) -o $@ $(OBJS) \
+- ${PILOT_LINK_DIR}/libpisock/.libs/libpisock.a $(LINKLIBS)
++ /usr/lib/libpisock.a $(LINKLIBS)
+ clean:
+ rm -f $(OBJS) $(TARGET)
+